Transferring files to PPM

Hey everyone! Happy with my PPM, taking it for movie nights outside every time I go camping though bringing a laptop as well to broadcast movies via hdmi connection is tiring. Is there a way to transfer files directly to PPM (to ssd in it) from PC or Mac using a USB? Or is there any other way for transferring files avoiding buying card readers?

I’m just trying to work this out myself. There’s a guide on how to copy files to internal storage that I’ve tried to follow: How to copy files to internal storage – Philips Projection

Unfortunately when I try it it doesn’t give the options the guide refers to, e.g. “A prompt will appear asking you to choose between Internal or USB connected storage (or SD card if inserted). In my demo I clicked on USB.” I’ve tried this with a few different USB thumbdrives but no option for choosing USB connected storage ever appears. This is particularly annoying when Amazon Prime is now borked, and the only way to fix this is to copy across an APK with an update.

To be honest I have never tried to transfer files to the internal drive of the ppm, simply because the storage is so limited at 16gb total, when you take away the apps OS etc you are left with 12gb at most,
My personal use has always been the micro sd card, but since you have mentioned not wanting to buy a card reader( though it’s cheap and even built in to lots of computers), then I would suggest a usb flash drive, surely any pc or laptop would have one of those, and they are very cheap to come by especially if you consider 16gb or more to be sufficient for your uses, and most of us should have one laying around somewhere

Resilio Sync works in the PPM. This syncs all files put in the shared MAC/PC/RPi RS folder to whichever PPM folder you set up on SD, USB, or internal.

Do you know if a USB-C flash drive would work?

No I don’t think it will, the 2 usb c ports are one for power the other for display only, I have a usb c portable ssd which is basically just a flash drive and that only works with the usb a port.

That’s a shame, thanks!

Perhaps a USB A to USB C adapter should work if you really want to use it