TV app ( Shahid ) Not working

@PhilipsEngineering a TV app ( shahid ) not working after installation from aptoid store

Shahid is an App same like netflix but it is popular in middle east

After installation when i open it a black screen appears then close and retrun to home screen could you advise please

would it be possible to add a small video here?

Hi @Dedohamdy

Have you received the projector in Saudi Arabia?

1 Like

@imdevu You can see short video on below link shows the app crashes when i try to open
Black screen then projector home screen

looks like the link has restricted permissions. Can you make it more open so anyone with a link can access. thanks.

@imdevu You can check now

@PhilipsEngineering: Not sure if you can check specific apps, but I’d imagine all apps should run fine.

@Dedohamdy: Can you figure out the app version number from settings?

Official link to the app:

With adb debugging it’s possible to capture the crash log, which in turn might explain more about the cause of the crash.

@Dedohamdy I had a similar problem with an app from my local cable tv supplier, and it was because it could not reach a login page using the browser. What solved the problem for me was to install a different web browser (other than pre installed firefox. I used dolphin browser) and make this the default browser (when you run it for the first time it will ask if you want to do this). After that my local tv app worked like a charm.
Hope this could maybe help solve your issue.
Best of luck

2 Likes

Hello all, there are thousands of apps, it is impossible for us to check and debug every 3rd party app. Quite frequently, the apps make certain incorrect assumptions, like assuming that above certain DPI is always a mobile phone, or that the device is in portrait mode, or that GPS is available. So realistically, we do not have the resources to debug all 3rd party apps by ourselves.

Please contact the app developers and work with them to pin point the issue. PicoPix Max owners who are technically inclined, are welcome to do some debugging via adb (we do not block it).

If the root cause is found to be a problem on Philips’ side, please let us know. We will then be happy to work directly with the developers, modify our software and make it work. Thanks for understanding.

The two exceptions to the above are:

  • apps that depend on Google Services will never be officially supported, this includes Chromecast. There is “Google Cast” service built into the Picopix Max, but this is different from Chromecast.
  • apps that block playback of copy-protected (DRM) content through AirPlay, Miracast or Google Cast, cannot be supported.
2 Likes

Thanks for the reply Prashant and that is what I would have thought.

@Dedohamdy: If you are technically inclined, can you try the option shared by @PhilipsIvo and/or reach out to the app developers for some help. Thanks.

@PhilipsEngineering there is a message appear now due to non availability of google play services the app will not work

How i could solve this issue ?

Moreover during mirror casting this app from mobile the casting is hanging and screen freezes on projector

If the issue is this:

Then unfortunately it will not work:

Some apps say this but work just fine, others don’t.

Any otherway i can comeover this issue like installation of any other software