Updated but now not working

I just updated the software and the projector restarted. The initial logo splash screen comes up and then the projector just displays a faint white image (see below). The main desktop screen does not load it just sits on this white image. Any suggestions?

1 Like

My battery setup has gone haywire…calibrated …charged full once.at night when played a movie connected to charger instead of staying at a constant charge went down to zero.
Recharged again in morning …saw it go upto only 4% and then it started going n reverse.
Hurriedly reset…but no luck…not charging now

Hello, we can offer you to exchange it. Please send a PM to @Philips_Support_N

1 Like

Do I need to exchange it ? You replace with a brand new machine right ?
I appreciate the offer.
Is there no other solution ?

@Philips_Support_N @Philips_Support_N
Please try looking for a solution first with Ur tech team.post update it charged fine.
Next day didn’t carge beyond 60%.
Next day after calibration went upto 98%.
Same night while connected to charger at 96% it went down to zero in 1hrs 50 minutes normal mode.
Now it’s not charging beyond 4%.
Reset again twice same situation

Dear @Philips_Support_N Anatoly Wang (one of the backers)solved my problem by suggesting I try the recovery factory reset instead of the regular one and it somehow worked.

Thank you for immidiately offering to replace.
I would just suggest you tell people to try certain toubleshooting before that

Excellent and prompt service I must say !!
Keep it up !