I got my picopix a few months ago and tested it. It started and worked on my wall although a bit dull, I had expected more brightness and lumen. But anyway I packed it in the box. Now several months after I unpacked it to use it but it doesn’t seem to work anymore. The green light is ON but other than that it doesn’t respond to anything and no light from the lamp. If I unplug it the green light disappear so I guess the battery is totally dead too.

How do I get this solved?

Probably you drained it first time and store it like that…
Try leaving it over night on a charger(plug it to correct port this time; far right) and next day try to hold power button for few seconds…
P.S. never leave the electronics with battery stored with empty one

A device should never drain the battery to the point of no return, though, that’s what a battery management system is for.

1 Like

Wow. Not even an attempt to help me. Just an assumption.

Let me tell you that I got it and charged it to 100%, then let it drain 80% before I put it back in the box, and then didn’t use it for some months because of the corona closed our need for using it because we don’t visit customers. And anyway its working fine now. I had just put the USB c charger plug into the wrong USB c plug in the unit.

But nice to know how you went out of your way to help me. Lol.

Hi @JimG, when you say green light, do you mean the little LED on the projector? If yes, then please check that you’ve plugged the USB-C cable into the POWER port, not the video port! The power port is the one on the right. It should show only blue or red, green is when USB-C video is connected.

Never mind, glad you found it out!

Thanks for your help. That was exactly what was wrong lol. I did find out myself before your help. But thank you for responding.