V1.1.01 service update available

Hi beta testers,

We have an urgent fix available for testing and release:


The changes are:

  1. Graphics fix when not using 4CC is now remembered across reboots
  2. Disable HDMI CEC, fixes this problem
  3. Preloaded applications are updated:
  • Kodi v18.6 (newly added)
  • Hulu
  • VLC 3.2.11
  • Amazon Prime Video (should solve lots of users’ problem)
  • SmartYoutubeTV 6.17.540
  • ExpressVPN (Philips ed.) 7.13.0

Please test and let me know your feedback.

We plan to release this tonight or tomorrow due to the HDMI CEC overheating problem. So unless a roadblock is found, all other bug fixes and improvements are being pushed to v1.1.02 for next week or so.


1 Like

I’ll download it within the hour!

Is this beta?

no it’s meant for release

1 Like

It seems graphics fix is permanente now
Nothing seems to be broken so far.


For some reason my unit found the update.zip just fine but only gave “Error!” after rebooting (Android recovery) when I used a USB3.0 USB memory but ran perfectly when using a stone-age Corsair USB2.0 one. Known XHCI issue in recovery?

Issue is not known, I use a USB3.0 drive to test updates. Please do report if this happens consistently with other drives.

Applied 1.1.01 update successfully, however:

  1. Manual keystone correction is NOT remembered after a power off / on cycle.

Cannot write to SD card bug remains in 1.1.01 as well.

  1. I had turned off CEC manually in 1.1.0, and I verified they are still selected off in 1.1.01 as expected.
1 Like

I can read from the usb3 drive just fine when android runs, and offline updater picks it up, but recovery just throws the “error!” and reboots,so it’s only the updater that fails, but it’s obviously not all usb3 drives. I’ll test some more!

1 Like

Re-download it to another medium or stick, perhaps the image itself was corrupt.

Update went fine so far. I can confirm that now with this release compose_policy = 6 is remembered. So Kodi is fine after reboot. - However writing on a SD Card or USB-Stick with 3rd Party apps like PowerPoint or X-plore is still not possible. Is this bug currently confirmed or reproduced by Philips team ? I think this is still a big issue for users working with the PPM and PowerPoint, Word etc.

1 Like

Update went fine, just one thing I’m not sure about if it has worked before:

When using the…


…to install the current Disney+ App, I was not able to change to the attached USB Stick. Workaround was to use the native filemanager and copy the APK to the PPM/PPX Internal Flash and install from there.