Video stuttering issues with latest firmware

Installed the latest firmware today and now video periodically freezes and pixelates for about a second at random intervals, similar to what happens when the camera is automatically keystoning.

This happens regardless of context or input: HDMI, YouTube, casting, or even just idling on the home screen. It’s fairly distracting when attempting to do anything.

Everything was perfectly fine before this firmware. Is there any way to downgrade?

1 Like

Have you tried factory reset?
I didn’t encounter those issues when I upgraded to the .25 firmware.

I have with no luck. Also tried turning autofocus off/on and auto-keystoning off/on and neither worked.

The one thing that’s worked is turning off auto-keystoning, but then I need to manually keystone which isn’t great.

Looks like this person’s having the same issue: Random Stuttering Playing Video File

1 Like

Which app are you using?
I had the same kind of issue with Netflix, but Plex seemed to be playing fine in my case…

Philips has posted guidance in this post…

Hey PhilipsPrashant, I still haven’t solved this.

The projector’s on a stable surface. Turning off auto-keystoning resets keystoning completely, so basically no keystoning. I’ve tried factoring reset twice. It happens on every input setting and even when idling on the home screen.

Is there a way to at least get the 1.0.24 firmware and would it be safe to install? This started happening immediately after I installed 1.0.25 so I’d at least like to give downgrading a shot.

Same issue. Using the crap tripod, stands on the wooden floor, still microstutter in netflix or with aircast. Enough bandwiths available, firmware is 1.025. How can that be?

Hi @Dobs and @Jens, you can put the projector where you want, with keystone active. And when you’re satisfied, turn it off only then. The keystone correction will stay where it is.

Are you saying that when you turn it off, the keystone correction resets back to zero??

I have also seen that the Keystone correction seems to kick in quite often, even if the projector is placed on a table and not moved. Seems to be very sensitive. Is there some kind of hysteresis when it gets activated and not, or do only some gyroscope values need to drop over a limit to activate auto keystone correction ? If there is some kind of hysteresis then it seems to be too small/sensitive…

Agreed it’s a known issue and will be improved.

Nice to know, I will keep this in mind next time I get the issue.
The floors are really soft at my place and it tends to shake a bit every time someone is walking upstairs…


Same behaviour here, turning off auto keystone resets it back to zero, meaning I can’t have a corrected image without stutter at the moment.

The projector is on a very stable surface but the issue still happens (stutters every 10s or so)

Waiting for the next update to solve these issues :pray:

Tried. Became better after turning of automatic correction and using a solid tripod, but still no smooth playback. Really disappointing.

Hi guys, just to update you, we are working on a solution for this issue. I can confirm turning off automatic keystone will completely turn the correction off.

1 Like