Will a future firmware update fix my issues?

I have so many issues with my unit that it is virtually unusable. Should I wait for a firmware update or request a replacement unit?

My detected issues are:

  1. Had issues initially to update to the latest firmware. The update button triggered a 100% black modal and a loading symbol on top, but it was not possible to see what was happening. I left it for a long time but realised nothing was being installed. Only after trying again and instead clicking the button “re-download” would it allow me to update the firmware. AFTER having done the firmware update, I had the following issues (some/many of them was already present before the firmware update. I’m only specifying so you wont tell me to update the firmware, because I already did):

  2. Unit freezes and requires hard reboot after random amounts of time, but mostly after 5-10m of being active.

  3. VLC app player streaming not working. Old VLC player version causes shut down after ~1 minute of playing successfully, and adter updating the VLC player it wont start at all. Shuts down instantly.

  4. Netflix app player is not possible to update. I get “App not installed” when attempting multiple times. The current version of Netflix does not work because it says I am not connected to the internet, after having logged in and selected an episode and clicked play. However, I am connected and I am able to watch Youtube (before I get errors) so I can confirm I have no connectivity issues with my Wifi.

  5. Streaming through mobile phone Netflix works for a limited time, until the video freezes and often the screen goes dark and only audio works (same happened with Youtube)

  6. Video stuttering sometimes, and sometimes it plays smoothly.

  7. Mouse cursor not working when using the remote

  8. Cannot access files on my Android mobile phone after connecting it to the unit and enabling file transfer

Thanks in advance for taking the time to read this and advise me on how to proceed. I just spent a lot of money on this unit and I expect to get what I paid for. If not, I want a replacement unit and all costs connected with the replacement NOT paid by me. I paid enough already (for a product that is not in any way usable at the current moment).

Joakim

1 Like

Try turning OFF automatic keystone and see whether it solves the problem.

As for the remote, have you done the Bluetooth pairing yet? The remote is working using IR if you haven’t done the Bluetooth pairing.

1 Like

Hello and welcome to the forum!

Can you please try to perform a factory reset? Don’t update Netflix afterwards. Smart Youtube is also preloaded.

If you’re still experiencing these issues, you can directly write to support@screeneo.com and explain the situation as it might be a defective device in which case you can request a replacement.

Cheers,

zIt seems to me that you have a faulty unit since most of your issues are not encountered by many.
Try the advice given but if still nothing, I guess you need to have it replaced.

As for #8, I don’t think Android supports MTP server. MTP is the technology used by Android to connect to PCs. Most desktop OS supports this but most likely Android can’t act as the server and can only act as client. If your phone supports other file transfer mode, you can try that. Some phones can present as an SDcard.

I solved the bluetooth problem, thanks to your reply so thanks for that! I find the lack of instructions frustrating with this product. I realize now that in the quick-start guide which is 90% images, there is a tiny screenshot of a “easy setup” part (which I never got to do nor can trigger inside the unit) that explains how to connect the remote. I had to use a magnifying glass in order to read it.

I will try to play around with the automatic keystone. Currently the lag has disappeared but if it appears again I will try your suggestion.

Anyway thanks a bunch :slight_smile:

Thanks, I tried it and although it didn’t roll back to the original firmware (tried the factory reset twice), the rest was reset and now Netflix and Youtube seem to work. I will get back to you in a few days with an update about how it has gone after some time has passed. I also haven’t experienced any more freezes so fingers crossed that my main issues are now resolved :slight_smile:

1 Like

It’s not ready yet, will be in a future software update :sweat_smile:

Hi @danopia and @Vin.

I have now done some further testing, after having done the Factory reset like you recommended (which fixed a lot of my initial issues) and have experienced some additional problems which I still have to date:

  1. Random freezes of varying severity:
    a) Least severe: Freezes and screen edges looks a bit sharp (like a saw). I restart the device and it works fine.
    b) Most severe: Freezes like mentioned above, but when restarting makes only the fan work and nothing is projected on the wall. The device seem to freeze even before this feature is activated. I tested some more and I also experienced freezes many times in a row and even in the middle of booting up (in the loading screen). After 3-4 reboots I could use the device fine again.

Bluetooth issues:
After having successfully paired the Airmote, it worked fine for around 2 weeks. Then now the last few days, after having connected my Bluetooth speaker, the Airmote remains paired but won’t connect. I only managed to connect it after unpairing it and pairing it again. Then the next day the same thing happened and I fixed it the same way. On both these occasions I had turned my Bluetooth speaker on first, before the PicoPix. However, I noticed that after I unpaired my phone + started the Picopix without turning on the Bluetooth speaker first, the Airmote connected successfully again. The last 2 days I have repeated this sequence and have not experienced anymore Bluetooth issues.

Netflix issues
After finishing an episode using the built in Netflix app, and another episode tries to load, I get the message that Netflix doesn’t work at the moment and that I should make sure I have connection to the internet. Restarting the app and finding the next episode manually seems to work 1/3 of the times, but most of the time I get the same error message.

File manager issues

  1. When navigating between the USB and the Internal storage, it sometimes doesn’t update the directory list on the right hand side until I start moving up and down. Meaning: The Internal storage momentarily displays the contents of the USB.
  2. When copying some files from the USB to internal storage, the “loading” circle which displays how long it is left gets some random numbers (example: “13128¤"31”) and the animation freezes. I have no idea when the file transfer is done and I have to sit and wait for some extra time to be sure that it is done and I can start watching what I transferred.

Bluetooth earphones lag

  1. When I use my bluetooth earphones (new, good quality, and works fine with all my other devices) I experience a lag when watching an episode of a series that I have stored on the internal storage and watching using the built in VLC player. It is just about 0.3 seconds delay, so it is not super bad, but it is a bit annoying.

Issues casting Netflix
I can cast Youtube fine to the PicoPix but when I try to open Netflix I dont get the option to cast (the icon does not appear). So casting works, just not with Netflix it seems. I know it has worked before though, at least connecting it. Then I think the device froze, but at least the connection worked. Now it does not.

Anyway, I hope this helped and I also hope you have some directions for what I can do to fix these issues. Do I have a broken device?

2 Likes

Hi Joakim,

Thank you very much for the throughout testing. Seems like you have a faulty device (although some of the issues seem connected with the software, but the freezing is more disturbing) and I advise you to write directly to support@screeneo.com . You can explain the issue and ask for replacement. Also give them a link to this thread.

Philips mentioned that replacements will be first priority after the factory gets opened on 24th - fingers crossed that the government won’t extend the quarantine period.

Cheers,

Hi Velislav!

Thank you for such a good and quick response. I have now emailed them.

Hopefully things will work smoothly with the replacement. It is not the mest time to ship things from Asia it seems. I fully understand if it will take some time. I will just use the faulty device until the new one arrives, since I can at least use it to some extent. :slight_smile:

1 Like

@Joakimbe please be aware that @Vin is a moderator, but not a Philips employee. Only @PhilipsNono and I are on this forum from Philips.

You were sent a return form and your ticket was escalated to me afterwards, because our help desk agent believed you were asked by a Philips employee to return your PicoPix. All your issues are software related, which can either be solved now (e.g. VLC audio delay), or with upcoming updates. In my opinion getting a replacement is unnecessary. Unfortunately I didn’t have a chance to look over your post until now…

2 Likes

Roger that. In my defense I have no idea who works for you and who don’t. I am simply a customer. Well, I bought a product from you that does not work as promised, so since you say these things can be solved without a replacement, I eagerly await your solution so that I can enjoy this product as I had hoped when I chose to purchase it. I hope your next reply comes with some instructions for what can be done about this :slight_smile:

1 Like

@PhilipsEngineering I am still waiting for your help to solve my issues

Hello @Joakimbe have you installed the latest software update? If yes, you can also try installing the latest beta version if you Join the beta testers list.

Most of your issues are software reliability problems that will improve with updates. Some issues which need remark are:

  • Netflix network issues: please run a network check from Netflix’s help menu to make sure it’s not a network issue.
  • Bluetooth lag: in VLC you can adjust audio delay compensation. Otherwise you may also use MX Player Pro which is my preferred player. It has auto compensation. Different headphones do it differently, you may need to pause and resume if the delay drifts.
  • Netflix cannot be cast wirelessly, they block this feature due to DRM. Actually any app that uses DRM cannot be wireless cast, as these apps only allow casting to official Apple TV or Chromecast, both of which are not licensed out anymore. However AirPlay 2 is being licensed and we are trying to get this for PicoPix Max.
  • Latest VLC crashing on latest PPM firmware is a known issue, will be fixed.
  • If you face issues doing online update, please try doing an offline update.
  • Video stuttering randomly: this issue is fixed in 1.0.26, it was due to auto keystone.
  • Cannot access files on Android phone: make sure it uses Mass Storage protocol (like a USB stick) and not MTP (like a camera). Also make sure to use the USB-A port, not the USB-C ports.
  • Netflix app should not be updated, it is specially built for PPM to allow Full HD playback.

With all that said, since you are experiencing hard freeze every 5-10 minutes, it could be a defective hardware. Do you notice any pattern for when it freezes? What if you turn it on and leave it at the home screen? What if you play a downloaded video from USB? What if you play Netflix? And what if you browse the internet? Which power adapter are you using? Which cable? And finally which brightness mode are you using (Energy Saver / Normal or Presentation?). What is the room temperature and altitude?

I want to establish a pattern whether it’s a hardware or a software issue, and if hardware, is it a thermal issue or not.

Thanks.

1 Like

Hi @PhilipsEngineering,

Thanks for such a great reply. I have been testing a bit, but before I give a full update I want to test some more since I just installed the new update. After the update, though, I experienced the device freezing after having watched around 30 minutes using the Youtube app. The video froze first and the audio kept going for a while but ultimately I had to restart the device.

About the DRM topic. I guess this means plugging a Chromecast won’t work on the PicoPix Max? The reason I ask is because it is not possible to play HBO stuff on the device. The built-in app does not seem to be supported. I get an error message saying exactly this.

About the freezes BEFORE the update:

  • It happens when it is idle on the home screen, or during watching anything on Youtube (like described above), or Netflix, VLC (video through USB or internal memory both) or simply by using it normally. I can’t seem to find a pattern.
  • The power cable and adapter I am using is the one that came with the device (EU), plugged into a power junction box (not sure about this word in English). Device is on power saver because I prefer the lower brightness. Room temperature is exactly 23 degrees and the device is 185 cm above ground level.

Hi @Joakimbe,

It will work fine. However please notice a couple of limitations: INFO: Limitations of features for HDMI and USB-C inputs.

Please let me know what you find after your testing. If you’re technically inclined we can also check the device logs to find if it’s a software crash, or a hardware problem. If the latter, it’ll be exchanged.

Hi @PhilipsPrashant !

Thanks for the good replies. I’m not sure how the device logs work, but I will share some observations below and I hope it will be of help to you and your team:

  1. Device freezes: Freeze when started 2 minutes in, after plugging in power (battery was on red). The screen blinked once as I put the cable in and then everything was frozen. Then it froze twice more after trying to reboot. First during loading (the little loading circle) and then when I rebooted again, the screen wouldn’t come on. I tried rebooting twice more without success.

  2. Airmote issues: The next evening it worked when I started it, but although the airmote was still paired, it did not connect. I restarted the device but no change. I tried manually connecting it but it just says “connecting” for a while and then back to the stays “paired” again, but not connected. This has happened twice before when I first got the device. It fixes itself if I unpair and pair it again.

Hope it gets better in a future update! :slight_smile:
Joakim

Hi again @PhilipsEngineering

I’m starting to regret I ever bought this product. The problems never seem to end and I don’t even get a replacement unit.

In all fairness, I have used the device successfully since my last post here with the latest drivers installed. But now the problems start happening again.

This time it was triggered by using Netflix (but I’ve had this issue before from using other apps or just starting the device and not clicking anything), whilst on 60% power and charging. After 2 minutes of scrolling around to find a show I wanted to watch it froze. Thereafter I restarted the device and got as far as the Netflix interface beforeit froze again. Twice more it froze but I managed to watch 5 minutes of an episode until it froze again and this time restarting it resulted in a freeze on the startup process and I’m the end I’m stuck with what you can see in the image I’ve attached. Repeated tests have shown that this mostly happens when I try using Netflix.

Usually letting the device rest over night gets it back to working fine, but I want to be able to rely on this product. What use is a portable projector if I never know if it will work? What if I want to use it at someone’s birthday party? It could end in disaster. I’m tempted to ask for my money back. It’s been nearly half a year since release. I’ve expected the issues to be over by now.

What can you do to help a customer that has tried his hardest to be helpful and patient through this whole long process?

@Vin @PhilipsEngineering

The device has now stopped working, or at least I couldn’t get it to start the whole day. Please help.

The issue seems to be connected with me charging it. I suspect a faulty power supply that probably overload the device somehow. Just my guess. At this point 50% of the time don’t beam any light and the fan starts dying down. If I’m lucky I can get some light and maybe even to the loading screen before it freeze again.

@Vin @PhilipsEngineering @PhilipsIvo

I am still not hearing anything back from you. Is this the level of support here? I feel really unsafe using Philips products now, and I think the best thing for me is to ask for my money back and go with another brand. Please respond!

Also, the device is still not working today. I got as far as settings and re-pairing the Airmote this time, and then it froze and now I cannot access the device again. I think I have tried long enough to make this work.

Again, PLEASE RESPOND!

1 Like