Youtube No 1080p

Haven’t watched YouTube for a while but today I noticed a new upload wasn’t as clear as it should be, so went in to the quality settings and noticed it’s on 720p which is different as usually it defaults in 1080p,
when I scrolled up to 1080p or any other setting I got the notice of “Cannot switch format while preset is active”
Now I haven’t changed any presets, then went in to the aptoideTV store and updated the app as I previously ignored the prompt to update but that didn’t make a difference, so right now YouTube is stuck on 720p for me, can others check if there is this issue as well or is it just me? Edit, btw I tried on more than 1 video and it’s the same

1 Like

Tried it again in the morning and no changes, also when scrolling through quality settings it was slow and unresponsive once the app even crashed and went to the home screen,
I even tried to fiddle with the main settings by pressing the back button when first launching the app and no changes either, not sure if it’s firmware update that made it incompatible with the app, hope others can check this as well,
Or I might uninstall the app and try again later tonight

Hi, is this YouTube or YouTube S? Cause I thought so far that YuoTube was not fully supported on the PPM and we should use YouTube S. Do you have the same issue there?


Sorry yes I meant YouTube S , the YouTube app that’s preinstalled with the projector

I’m not sure if Smart Youtube app is in the aptiode store, is it?
In any case, you can update the app within the app as it always checks for new version and ask you.

Anyway, I’ve never used preset myself. I checked mine and it’s set to No restriction. You mentioned new upload, you mean a newly uploaded video on youtube? Because as far as I know, newly uploaded videos are not available in higher resolutions immediately. So perhaps that’s the reason you’re only getting up to 720p?

Also in my observation, the app’s behavior is that whatever you select in the Video quality settings will be the preferred quality, fps and codec. So if you select 1080p@60fps - vp9, then the app will try to use these in every video as long as they’re available. If not, it’ll use the next lower quality. Since the recent update, I want my videos to play at 1080@60 so I find a video with these available and set it in the video quality settings.

Happy to report I got 1080p back without restrictions, when I said new upload I meant a recent upload which I know is in 1080p even 4K and all that you mentioned also worked for me before and I haven’t touched any presets, but for some unknown reason it was stuck on 720p last night and none of the other resolutions can be selected as it will tell me it cannot switch format while preset is active,
anyway I tried a reset within the app just then and that didn’t work either, so I ended up uninstalling the app, and the smart YouTube app is available in aptoideTV, so I reinstalled, it then asked me if I wanted to restore my settings which I chose no, and now it’s back to how it was with all resolutions possible and defaults on 1080p, so thanks guys , lastly avc or vp9?

1 Like