Youtube not working anymore! PPM broken?

Since receiving the PPM I watched many many clips on (normal) Youtube by connecting to the ipad or iphone with a cable to hdmi what worked just fine. Via airplay I could even get the sound on my sonos with this setup.

But this doesn’t work anymore. Tried everything, even streaming youtube via airplay (what I hate because I give youtube access to my network, what actually is security critical from my point of view).

I didn’t change my setup, just the software updates. Sometimes the whole sceen stays totally black, sound is on on the sonos, the clip is running. Sometimes youtube shows, but the videoscreen is black, the sound is on (sonos) and the clip is running (from what I can hear). Sometimes the video plays on the iphone or ipad but not on the PPM, sometimes vice versa. The problems started last week. Once (one single time!) it worked since then. From one second to the other it worked for one clip. For the next clip it didn’t anymore. This is horrible UX.

To watch directly from the PPM is not a solution because I can’t get the sound on the sonos like that – because you failed to implement what you promised in the crowdfunding.

What can I do to save the show on this one? If there is no solution which doesn’t require me learning software engineering skills I want to return and refund (including taxes and import customs, which I will then invoice to you) this buggy machinery. @PhilipsNono @PhilipsIvo @PhilipsSteve @PhilipsEngineering

This product has caused me so many headaches that I will no longer buy any philips producs because you screwed this one up really hard. It started with the hdmi issues, then the not delivering on the sonos integration and now I can’t even watch a single youtube clip over my iphone or ipad. Really frustrating!

Is your HDMI cable ok?
Did you try another HDMI cable?

Did you try a Factory reset?

Hi @bernrhs,

We’re sorry to hear that YouTube videos aren’t working for you anymore. Since you’re using an HDMI cable, it is unaffected by any PicoPix Max software update (the HDMI input completely bypasses all the software). So the issue could be caused by the iPad / iPhone / YouTube app or one of the cables. Don’t worry we’ll help you troubleshoot it.

Could you please clarify a couple of points:

  1. Are you using an Apple branded Lightning-to-HDMI adapter cable? Or another brand?

  2. Does it work fine if you connect another device, e.g. your laptop or a phone from a different brand?

  3. Have you tried a different HDMI cable?

Thanks in advance.

Could it be that it was the iOS14 update that causes this issue?
What you can do however, is to use the internal youtube app and connect an Audio-to-Bluetooth adapter to your PPM and pair that one with your Sonos

I’ll try out all your suggestions and let you know if/what works. Thanks so far.

Unfortunately this doesn’t work because Sonos works via Wifi, not Bluetooth. Thanks.

Went with the factory reset and was not fortunate. I do think now that it has to do with the youtube app and the mirroring to the ppm.

But first:

  1. I do have an Apple branded Lightning to HDMI adapter cable.
  2. Couldn’t test this because it doesn’t work with iphone nor ipad. Will try tomorrow with a laptop.
  3. Yes, same problem with another cable.

What is strange, is that it really only happens with youtube. When I use other apps on the iphone or the ipad the clips work fine (e.g. amazon prime, netflix, TV station apps from my country) and I can stream the sound to the sonos without problems. It is really only the youtube app which doesn’t work with the ppm (via lightning cable for the video and airplay for the sound) anymore. It seems like the app wants to stream via airplay, doesn’t get a connection (of course, the ppm isn’t even in the wifi now) but the sound can be heard via the airplay on the sonos.

Do you have any tipps?

try to use the youtube website instead of the app

1 Like

This seems to work (however now I only have the ipad resolution, which is not as big as the ppm could do). Thanks!

So: It’s a fault of the youtube app! Funk Alphabet! Must have been one of the latest youtube app updates …
I do ask for your apology! I am sorry for being rude in my initial post.