YouTube, SYouTube, casting from phone not working

1)Basically no video on SYouTube works, it sends an error message. YouTube doesn’t even connect even tho WiFi is connected Nd working on other apps.
2) when trying to cast from my phone it doesn’t work.

1 Like


SYoutube Says this: Ooops! Seems the video link is broken. Exiting…

Hi @Mifuad, have you paired up the YouTube app on your phone, with SmartYouTubeTV on the projector, using the “TV code”? You should also turn off Google Cast by going to Screen Mirroring settings of the projector., if you primarily cast YouTube from your phone, since the Google Cast method conflicts with the SmartYouTubeTV paired mode.

2 Likes

I tried doing the pairing with the code given by the SYT app but still doesn’t work. Nor any videos play when I go on SYT even after signing in… before the Rockchip update everything was working smoothly, I could cast from phone/YouTube without any issues

Hi, is there a way to go back to the previous firmware/software. because as of now this projector is useless to me with nothing I need the most working! Not even bloody Firefox works

What are your Airplay settings like?

The problem isn’t even just the airplay stuff, but also BASIC YOUTUBE or SYouTube not working…

these are the airplay settings anyway

I also tried taking Google cast receiver option off. But still doesn’t work…

Have you tried restarting / closing Airreceiver using the option from the settings screen you showed?
image

Yeah I tried that too just now. Still doesn’t work

@HiB are you getting a similar problem?

@PhilipsIvo @PhilipsEngineering

@PhilipsEngineering @PhilipsIvo

Any further help regarding this? It’s really frustrating to not be able to watch even basic YouTube nd cast from the phone… this ruins the whole experience

Have you tried to reboot the router/modem first ? Then maybe a factory reset? Uninstall S YouTube then reinstalling It?

1 Like

Thanks a lot! That fixed the casting problem. I did factory reset of it. Earlier the PicoPix name was PPX620-111 and from my phone that’s what was showing and always tried to connect to that. After the factory reset the name changed to PPX620-105 which when looking for casting devices appeared and boom! It worked. Can cast phone and YouTube from phone, even if I keep all the options ON in airplay settings of the projector

2 Likes

The PicoPix max won’t cast content from phone or laptop again… and resetting everything again would be a pain to reinstall all the apps and add one added so far… What to do?

Hi @Mifuad this seems to be an issue with the WiFi network. Try turning WiFi off and on (on the projector, and if required also your wifi router), so that it re-connects to your router. You don’t need to do a full factory reset for this. Let us know if this helps.

Nope still doesn’t work with Android phone

Hi @Mifuad, please go to “AirPlay” settings from the quick shortcuts on the home screen (yes, even if you use Android). Then, turn off Google Cast on that page. Now, open SmartYouTubeTV app and go to its “Link with TV code” feature and relink the Youtube app on your phone with the projector. Let us know if this resolves the issue.

This resolves the issue with casting YouTube videos from YouTube app, however the screen mirroring doesn’t work