Airmote pointer not working

Hi guys,

I need your help, everything is well with my airmote.
Only now, the pointer is not responding. It is only on steady state when I am pressing the pointer button on the airmote.
All buttons are functioning well except for the pointer.
I tried to do some work arounds like unpairing and pairing the airmote to PPM.
I even removed and reinserted the battery.
Had to shutdown and turn on the PPM,
but all still failed to solve the issue.

Thank you and hope to here from Philips soon

Possibly your remote is faulty. Can you try pairing it to a PC/Laptop or Android? I think it should work like mouse on those.

Yeah, I think the airmote is faulty.
Tried to connect it to my S10+, all buttons are functioning.
But airmote pointer is not moving.

Thank you @kugiigi

@PhilipsEngineering
@PhilipsNono

Hi Prashant and Nono,

Any advice on this issue?

Thank you

Hey, I can recommend performing a factory reset, remove the batteries from the remote and try again from scratch to pair the airmote. If this does not work I guess this would mean a faulty remote.

Cheers,

Does pairing it to your laptop also doesn’t work?

Have you tried pressing the mouse button really hard? Just to find out if it’s a physical problem.

Otherwise it might be faulty (gyro not working).

I already tried connecting it to my laptop, still the same.
When I pressed the pointer button, the airmote pointer will appear on the screen as usual, but it won’t move.

Any other work around?

Thank you

Can I ask for replacement for the airmote?
@PhilipsEngineering

Yes, it looks like the gyro is not functioning anymore. Please email support@screeneo.com and clearly mention the product (PicoPix Max), paste a link to your forum post, and ask for the return form. Then, fill the return form saying you need a missing accessory to be shipped.

Hi @PhilipsEngineering

I’m facing the same issue - airmote pointer not working. I tried the following but they don’t work: 1) replace battery 2) pairing to laptop (none of the buttons worked).

Can I write in for a replacement too?

Hv u guys pairing it by Bluetooth?
Mouse pointer doesn’t work in infrared mode. It does work in Bluetooth mode. Pls try.

1 Like

Hi, thank you for the suggestion! I’ve always paired it using bluetooth though.

I had same problem, IR works out of the box, but you need to go:

  1. Bluetooth setting on PPM
  2. enable bluetooth
  3. On remote press & hold 5sec: “OK” + “Volume -”
  4. On PPM: “Scan for devices”
  5. Select: “Philips AirMote”

All works perfectly ✓

1 Like

I had the same issue only pointer is not working.

1 Like

Try connecting it in the Bluetooth menu. So not Unpairing and Pairing, but Connecting.
The menu contrast is a bit difficult, but the Connect button is there. I have the exact same speaker and as you can (almost) see, the button is there.


image