Bluetooth remote

When the PPM is placed behind the viewer, the remote needs to be pointing at the back in order to work which is a little weird for the user experience!

The remote in the PPM package is bluetooth but you need to pair it first. Then it doesn’t matter where you are pointing it.


You need to pair the remote first:

How to pair my remote control?
The remote control has 2 ways to control the projector: IR and Bluetooth. While IR works out of the box, bluetooth needs to be paired. In order to do so, please go to the projector Settings>Bluetooth. On the remote control, press OK+Volume- keys for 4 sec until the LED blinks. You should see the Philips AirMote appearing on the projector Bluetooth Device List. Press Connect on the remote control.


I follow the instructions to pair my remote but in thé BT list I only see MAC adresses without any label to solve who is who… any tip/idea?

Same here don’t see the remote in the list.

@Laurent94 & @the1anuj :
Try to stop/start bluetooth (toggle button) and wait for a while to see if the airmote appears under its name.
Maybe you’ll have to do it several times to make it appears.

1 Like

I got mine to work by pressing the OK & the VolDOWN buttons at the same time. I would recommend trying different combinations of the Volume buttons (since there are three, VolDown, Mute, VolUp).


Press (OK) and (Vol-) for 4 seconds. Red LED will blink. In the list of found bluetooth devices, you will then see Philips AirMote

@everyone, it’s better to point people to the support center article or the forum post to avoid repeating the instructions which might be slightly different than the official guide. In the official guide you can see one more step, “click Scan for Devices” - when this is done, AirMote shows up as the first device, with the name too.

1 Like

No it doesn’t show up! Tried it 20 times to no avail…

have the same issue… any work-arounds?

Does the red LED blink or not?

Hi Ivo, thanks for your time. Yes it blinks red several times. Tried everything to pressing after 1st blink till waiting to press both buttons after the remote stops blinking. I’ve made also sure I point the remote towards the back of the device where the IR-sensor is. I’m out of options here… #frustrating And why didn’t they not decided to press pointer + on/off button instead of on/off VOLdown button. That’s far more intuitive not since you need the POINTER to work and not the volume button…

Hi @BlueBlotBlues it is [OK] + [VOL down] at the same time, not the on/off and vol-down. Please try that combination.


Works like a charm Ivo. Thanks a lot!

1 Like

Pointer works well, but when i press ok… nothing happens. Help…

Unfortunately this is not a bug, you “click” with pointer button

1 Like