Cant update or install anything in the PicoPix Max

I bought a week ago the picopix max , I installed the latest update and everything worked normal, but now it does not want to install any app or update anything, but internet access remains normally working, when I click “install” on " home screen launcher, A new version 2.4.4 is avaible" nothing happens, the same happens with any other app.
I have tried entering the advanced options and giving access to all applications to write files, without success.
When checking “installable apps” the applications I tried to install appear, but the file size appears as 0.000B and when I click on any of them the phrase “there was a problem parsing the package” appears.
i also tried changing the internet connections but the issue remains.

To be more specific, when I click on an app it tells me that if I want to install it, I click on it and the black bar appears and quickly becomes white, that is to say that it does not download anything and does not install or update anything, I tried to restore by cable after doing the factory restore that comes inside the picopix max trying several times without any success, I tried to restore it to a previous version and the problem persists in the previous version, (I imagine it may be a bug of a file to which I do not have access).
I need to emphasize that the internet is working normally since I managed to download the latest update again.

1 Like

Please install manually this launcher via USB stick and try again: - Envoi sécurisé et gratuit de gros fichiers

I have the same problem. I cannot install the launcher either from the OTA menu or with the provided file through USB. I get the message “there was a problem parsing the package” with the second method.

To give some context, I reverted the launcher to the base version from the advanced menu because I had the Screeneo launcher icon present on the dashboard and I wanted to get rid of it. Guess I don’t have the problem anymore as I can’t upgrade it anymore…

My guess is that there is a problem with this specific version, because when I did the same with version 2.3.X there was no problem updating even from the base version. As there is no link to get the previous versions of the launcher, I have no way to test my theory.

1 Like

Maybe the file link you provided is not a working .apk since is very small size file and contains just a few lines of text inside:

Thanks for your response, I tried to install the provided apk but the message “there was a problem parsing the package” appears i also tried copying and pasting the file to the internal memory of the projector too and the result is the same , in the picture you can see evidence,

i also provided a link to a video, showing how nothing can be installed in the main menu, and also how the selected apps that i tryed to install appear in the downloads folder but the size remains 0.bytes and when i click in any of them the message “there was a problem parsing the package” appears too

I face the exact same issue but with other apps: myCanal, Amazon Prime Video…
I get the same error message “There was a problem parsing the package” when trying to install the apk from the file manager.
Is there a way to force the download of the apk again?

1 Like

And i have the same problem “There was a problem parsing the package”

the file on the link is erroneous

1 Like

This post was flagged by the community and is temporarily hidden.

@Philips_Support_P can you post the launcher on our secured server?

Hello all, we are working to solve this issue as soon as possible.

1 Like

problem solved. can be updated

??? Ok

how did you fix it?

Sorry. Not fixed. Its a question for Philips Support

Has there been a fix yet?

Hello all, sorry for the delay. The issue has now been resolved.

1 Like

i can confirm that the issue has been solved, thank you so much!