Charging - Led blinking blue and red when plugged


I have several charging behaviors that seems abnormal.

  1. When plugged in with original charger, the led is constantly blinking red and blue (when projector is powered on or not). I guess that once fully charged, the LED should remain blue.
  2. The battery icon is never full in the home screen (see attached picture). However in the settings screen, it appears full with an additional charging icon.
  3. It seems that shutdown is not a real shutdown, more probably sleeping mode because it is still possible to wake up the projector by using the remote. I think that it is draining the battery little by little. I would prefer to totally shutdown the projector.
  4. Even if it is in sleeping state, the date and time are not saved. When projector is not connected to internet, the date goes back to 2016 (see pic below)

Have you experienced similar issues? Or is it specific to my projector?
Do you know if developers are aware of them? Is there a bug tracker where I can submit a ticket?

First firmwares were really buggy but it is becoming better and better. Can’t wait to update to tomorrow’s update with reduced fan noise! And also expect much about better integration of KODI. I hope that Philips will continue supporting this device with regular updates till it is really finalized.

1 Like

1 & 2:

  1. I believe this has been proposed before but I don’t think it will happen soon

The upcoming firmware update will improve the performance of Kodi on the PPM, not integrate it further. It’s still optional to download, not preinstalled.

1 Like

I have the same problem and the reason seems to be a “defective charging chip” inside the PPM -Support is checking how to handle this, probably with a RMA.

Before contacting them “you can also purchase any inexpensive 60W power adapter, which will charge the projector when off, at reduced 45W power since most of them can’t supply 4A current.”

If the problem doesnt exist with the Third-Party PSU, then “you should contact support to get a replacement power adapter and cable first. Only send in your projector if that doesn’t solve the problem.”


As mentioned, I only use the projector with charger provided with it (“original”).
I will check how to directly contact support then as it seems charger or PPM charging chip is defective.

Please use


I received also my projector 4 days ago
I use the charger and cable included in the box with UK plug
It charges fine (red light) when plugged but when the battery appears fully charged instead of the expected blue or green light (not sure which one should be) it flashes red-blue which normally indicates an error. Not sure what’s happening
Otherwise the battery charges ok and the projector functions normally
Any suggestions?

1 Like

Are you sure that your battery is fully charged? I have same issue. It is red at the beginning of the charge but it is blinking before the charge is completed. The software indicates between 55 and 75%.

1 Like

I’m running into similar issues with charging, but I only noticed after updating to firmware 1.1.0 . All with original Philips adapter.

After the update, the big new charging status in the top left of the screen said 76%. When I plugged in the power, it would very slowly over an hour creep to 82%.

I turned of the beamer, let it charge for a night, the next morning after startup the charge level was 76% again, huh? That’s when I started to test further.

Yesterday when I plugged in the official power adapter agaub the led on the PPM started to flash with regular intervals between blue and red, but the adapter makes a chirping short noise every 3 seconds: After 5-10 minutes the switching interval from blue to red on the PPM becomes erratic, anything between 0.3 and 1.5 seconds. Unplugged the power.

This morning I checked the PPM after it had been unplugged for a day, and the charging indicator on screen was now 92% chargd. Huh?

I don’t have any other USB-C power adapter with 15V profile support at home, so I cannot test. My macbookpro usb c adapter has 5-9-20v, a raspberry pi 3A adapter only has 5v.

If I understand the messages above, I first have to find a compatible usb-c adapter to triage if my adapter is broken or the PPM is defective?

What if you try charging your MacBook Pro with your Phillips adapter? and alternate between the Phillips cable and the apple cable to see if any will work.

1 Like

Thanks for the debugging tips. I actually tested the macbook pro cable with the PPM and PPM adapter, forgot to mention it. But I didn’t test charging the macbook pro with the PPM adapter and it charges my laptop! So if something really is off it’s the PPM and possible the charging chip :unamused:

Amazing by the way how badly documented PD profiles are from consumer products. I realised I do have another usb PDF charging device at gine. I’ve been looking at it for 5 weeks: a new monitor which usb-c video cable which PD charges my macbookpro. Duh! But not a word on the spec sheet at which voltages it can charge: PD 60W.

1 Like

If the adapter and cable both work and since you only started getting this problem after the update have you tried a factory reset yet? If not that might be worth a try or roll back to the previous firmware, I don’t feel it’s hopeless yet,
Btw the battery percentage or time remaining may not be accurate when it’s first turned on, you need to run it for a little while and it will settle in

Last night while testing I also ran into this alternating police lights issue

However, it turned out that I hadn’t plugged the cable in correctly. After unplugging and plugging in again the issue was gone.

Note that I’m not saying that those with the symptoms above aren’t plugging in properly or that there is no problem. All I’m saying is that for me, a simple re-seat of the cable worked to get rid of the alternating LED.

So if you run into this issue by all means try some of the suggestions above to troubleshoot, including a simple unplug and plug, making sure the connector is properly seated.

So if you run into this issue by all means try some of the suggestions above to troubleshoot, including a simple unplug and plug, making sure the connector is properly seated.

I’ve tried to look up on this forum how to do a ‘factory reset’, but it is not in any of the setup menu’s and I haven’t found much in other news items, except for holding the power button for 30 seconds in one post. (edit:) But this doesn’t seem to trigger anything. With the PPM turned off it switches on when you hold the power button. And when you press/hold power when the PPM is turned on, it powers down, only to power on again after 5-6 seconds.

Could a ‘factory’ reset be documented somewhere prominent, below the guides menu perhaps?

Go to Settings > Software Update > Factory Reset to perform the reset please.

I have charging issues too, and yes, I did a factory reset after updating to 1.1.0.

Red and blue blinking, never stops, and:

Turned off while charging, the pico charges to 96% ( checking by turning it on) but never gets to 100% [EDIT] : Well, it might, and then start decharging?
Checking after 2 hours more, the battery is now at 85%

Now charging, whilst turned on, it seems to be charging again, slowly got to 86% .

[EDIT]: Upgrading to 1.1.01 now
[EDIT1]: stopped at 89%, charging while turned on with 1.1.01
[EDIT2] Charging further, while turned off = now 82% !
[EDIT3] Left it for a while, turned off, not charging = now 95% , when turned on.

No Feedback yet from the Support.

In the meantime my PPX now suddenly went off when I remove the USB-C Powercable, even when the launcher says the battery has :100:% capacity :confused:

1 Like

Hmm, immediate power off without the “Shutdown…” dialog? The flashing red/blue seems to be generated directly from the STAT pin of the bq24171 chip (

For some reason the blue LED is just an inverted version of the red LED (red LED is on when STAT pin is low, blue LED is on when STAT is high).

There are a few different errors all indicated by flashing, unfortunately TI combines them all into the same indication: “Blinking at 0.5 Hz when fault occurs,
including charge suspend, input overvoltage, timer fault and battery absent.”. Not super helpful.

1 Like

Hi @SchmuFoo I have escalated your ticket, you should receive a response asap.


Yes exactly, the battery usage possibility is completly gone.

Thanks Prashant, I have received it and filled the form now (For this please also see my Post in the “Staff” Category)