Compatibility with HyperJuice 100W GaN USB-C Charger

Are there any backers of HyperJuice here? Anyone knows for sure whether this HyperJuice USB-C Charger is compatible with PicoPix Max? I am considering getting the HyperJuice as a spare charger for the PPMax.

Am hesitant because I saw in another post that the MacBook 87W USB-C charger is not compatible with PPMax even though it should be compatible since it is capable of 87W output.

@PhilipsEngineering, do you know whether HyperJuice is compatible to charge the PPMax?

HyperJuice Specifications

  • Power Input: AC 100-240V 50/60Hz 2.4A
  • Max Power Output: 100W
  • Ports: 2 x USB-C and 2 x USB-A
  • USB-C1: 100W Power Delivery 3.0, 5~15V/3A, 20V/5A
  • USB-C2: 100W Power Delivery 3.0, 5~15V/3A, 20V/5A
  • USB-A1: 5/10/12W, 18W Quick Charge 3.0, 5V/3A, 9V/2A, 12V/1.5A
  • USB-A2: 5/10/12W, 18W Quick Charge 3.0, 5V/3A, 9V/2A, 12V/1.5A

Thanks.

3 Likes

Did anyone get a Hyper Juice and can confirm if it works with the PPM?

I have backed the HyperJuice on Indiegogo. They have started delivery to Kickstarter backers. Now waiting for them to start delivery to Indiegogo backers.

So I just received the HyperJuice last night. Did a quick plug in test using the original cable from PPMax. Looks like it works. The LED turns red and the battery symbol shows that it is charging. Will test it longer to see if the HyperJuice can charge the PPMax to 100%.

3 Likes

Update - The HyperJuice is able to charge the PPMax to 100%.

PPMax in Normal mode and only showing the shortcuts screen.
11:12am - 84%
11:42am - 91%
12:12pm - 98% (approx. 14% in 60 minutes)
12:25pm - 100% (LED red)

At 100%, I power off the PPMax but left the charger connected. The LED still remains red. I did not wait longer to see whether it turns blue.

3 Likes

Try to drain the ppm to below 50% and see if the charge rate can be faster than 14% in 60 minutes,
as a lot of devices starts to trickle charge after 80%

2 Likes

OK. Thanks for the tip. I will test it again and report back. Thanks.

2 Likes

Then maybe do the same test after with the standard ppm charger and have a complete comparison of the difference in charge rate both while switched off as well as on between the stated 15v 4a of the ppm and 15v 3a of most after market chargers and power banks,
Actually the rest of us can all test out the ppm charger too.

1 Like

Update #2 - Tested again after draining battery to 20%.

Charging PPMax in Normal mode showing shortcuts screen.
8:22am - 20%
8:52am - 26%
9:22am - 34%
9:52am - 43%
10:22am - 53%
Not sure what’s going on. It was 14% in first 60 minutes and then 19% in next 60 minutes. Overall, 33% in 120 minutes.

Next test was with the PPMax turned off. I turned on the PPMax after 60 minutes to check the battery level.
10:30am - 50%
11:30am - 87%
It charges 37% in 60 minutes.

2 Likes

Perhaps the battery charging circuit monitors battery temperature? I think it is a common feature. When I designed a charger circuit 2011-2012 the control chip I used had a standard port for a battery temperature sensor. My charger back then was for lead-acid batteries, but the same chip had features for lithium-ion too.

I would expect the biggest difference between a 3 ampere charger and a 4 ampere one to be seen in charging speed from highly discharged up to ~80 percent charge, especially while simultaneously running the projector in normal (or presentation) mode.

All standard USB-PD chargers with a 15 volt output should be able to charge the PPM to 100 %. It is just that some with a low current limit may struggle to do it quickly, or fail to do it with the projector active.

2 Likes

I’ve also got a Hyperjuice and just tried to power my PPM to no avail. I tried both the cable I got in the PPM box and another one but no power going to the PPM. I also tried my Macbook charger (61w) and this works just getting no power from my Hyperjuice to PPM.

Any idea why? I was encouraged to hear some success for users above using Hyperjuice so just a bit confused as why it doesn’t work for me.

Just bumping this. Anyone else get a Hyperjuice 100w from Kickstarter and manage to get it to work with the PPM?

No luck for me but confused how others above seem to get it working.

Sorry to hear you have problems. I just tested it again and confirm that it is able to charge the PPMax.

Below is a photo of it using the original PPMax cable.

That’s really weird as i’ve tried the same setup and get charging to my PPM. Just trying to troubleshoot why - if it’s something with my PPM or Hyperjuice.

Not had any issues trying to charge any other USB-C device (fine with Macbook, Google Pixel 3 phone, etc).

Could we possibly of had a slight different PPM? I got mine shipped a couple of weeks ago and was in list 3.

@PhilipsIvo - was there slight differences between battery/power on PPM? Just trying to work out why my PPM doesn’t charge with Hyperjuice, yet @williammuk is able to

I do not know as I’m not in the Engineering team or anything like that, @PhilipsEngineering might be better suited to tell you this.

But even with possible changes the same specs should apply.

With the unit off,

  1. does the Philips charger work properly with the supplied cable (you see a red light when you plug in the cable in the USB-C (POWER) port?
  2. does the LED turn red when you use the HyperJuice charger and plug in the cable in the USB-C (POWER) port, or does it start to blink?

yes with the boxed PPM charger and cable when plugged in it is a solid red LED.

when i use the supplied cable with the Hyperjuice there are no LED’s at all.

Any ideas @PhilipsEngineering ?

Hi @jashraf are you able to charge another device with your HyperJuice? If yes, how much power does it draw? From all the info so far it looks like your HyperJuice might have a problem. Have you tried all alternate USB-C ports on the charger? Are you using the USB-C (POWER) port on the projector and not the video? Can you try reversing the USB cable direction (which end goes to projector and which end to charger)?

1 Like

Hi - yeah i’ve been able to charge other devices (Macbook Pro, Google Pixel 3, Bang & olufsen speaker). Tried both ports on the charger and flipped the cable too with no joy. Also tried the charge cable i got with my Macbook Pro just in case too. It only seems that it can’t charge the PPM but everything else is fine.

Any idea on how i can get to the bottom of this?

@PhilipsEngineering would adb logging help? What should he be looking for?

I’m wondering about that. The charger LED is hardwired so if it’s detected and charging, it should be red (it’s not software controlled). Let me talk to the hardware engineers and get back to you.

1 Like