Cursor wont show up from remote

hello there, it seems when i press the arrow button on my remote, the cursor wont show up.
the cursur would show up (as a circle) if i use the touch pad, but it just refuses to show up from being pressed from the remote, it is causing a very frustrating experience. (the red light blinks when i press the arrow button, so the button itself is fine)

I have tried replacing the batteries, and restarting the device and also downloading the latest update. None have worked. All other buttons are fine except that it seems i have to hold the remote closer to the projector for their functions to be registered.

Please let me know what else i can do. Urgent.

like i REALLY have to point my remote AT the projector for it register the functions

@PhilipsNono

Is it the battery dieing? Seems to be a few of these type of posts appearing with remote issues, mine started playing up last night, I think it may be new battery time.

i replaced the batteries already :slight_smile: @PhilipsNono @PhilipsIvo

I TRIED THIS METHOD ON ANOTHER THREAD

    • Go to Bluetooth settings and select the Philips AirMote (press OK), then from the menu on the right, select Unpair.
    • Turn bluetooth off.
    • Turn bluetooth on; the remote should no longer be listed.
    • Now, press and hold OK and VOL– keys till the LED on the remote starts to blink.
    • When it starts to blink, only then go to the Scan for Devices option and press OK.
    • The AirMote will now appear again in the list, go to it and press OK. It should say Pairing → Paired → Connecting → Connected.
      When it says Connected, congratulations it should work. But if the LED on the remote flashes everytime a key is pressed then it is still in infrared mode, and not paired. In this case please try the above process again.