Factory Reset Button - clear app service login details

Apologies if feature already exists - did not find any info on this site

Would like a factory reset button on PPM unit - such that personal login details stored in PPM for app services, such as Netflix account details, YouTube details are deleted securely.

This is particularly relevant if the unit needs to be returned for repair, or unit is sold on to new customer etc.

In my case the lamp/light is not working in unit so cannot use the settings menus etc as no projection etc.

This functionality is already there, so apology accepted. :slight_smile: You can find it here: Settings - > Software update - > Factory Reset.

1 Like

Oh, I now see that you can’t access the settings menu since the projection isn’t working. This is a very special case, and I don’t know if it even is possible to do this in hardware. I guess it would have to be somehow done with the power button, since no other buttons are available. Also, I’m not entirely convinced that there are enough cases like this to warrant the work needed to implement this functionality in hardware. But this is of course something that the Philips Projection team will have to consider.

I’ll remove the solution, since it doesn’t solve your special case.

Hello @Telboy this is a very valid concern. There is no built-in way to do this, but if you connect your PicoPix Max to a computer using the USB-A port, you can then erase the internal flash completely using a special tool. The projector light engine does not need to be working for this. If you need this information, please let me know, I will provide it privately.


Hi @Philips_Support_P, yes please can you send me details on how to do this. Thanks.

Hi @djupsjob, I was thinking the PPM could be programmed to recognise a custom sequence of key presses on the remote control to achieve this reset process? The LEDs on remote could blink a number of times to confirm success etc.
Just a suggestion :slight_smile:

This we can already provide. Assuming the projector works but there’s no light, you could do the same key presses to get to the settings menu and start a factory reset.

I think (out of the top of my head) something like up 5x to be sure you got to Settings, then OK twice to enter settings, then down 5 times to be sure you are at the bottom line, then right once to get to Software Update, then right (?) to get to factory reset, then OK.

Can someone verify this when they next do a factory reset?

Hi @Philips_Support_P, please can you send me details on how to clear internal flash. Thanks.

Hi @Telboy sorry for the delay, hope you’ve not already sent it back. I will send you the tools and instructions tomorrow. It is an internal tool and therefore was not ready at hand.

Hi @Philips_Support_P, unfortunately DHL collected package today so we were not in time to clear settings. :frowning:

@Telboy oops looks like I’m 4 hr too late. Just finished uploading the 2 GB restore image after 4 attempts (on a slow mobile connection…)

Ok don’t worry I will take your picopix serial number and ask them to do the cable erase before anything else. It should be standard process anyway :thinking: because they will reprogram the latest firmware to it.

1 Like

hi Prashant, i am having this problem as well.
could you PM me the way to solve this?

thanks in advance.

Did you know what the issue was and how long did the repair take from shipment to delivery.

Any chance of making that restore and update firmware public? I’m in a situation where my picopix flashes the boot screen goes “black” and then is totally unresponsive to any input. All but when I plug in an usb-c cable in the video input. Then it displays the no video green screen of what I can see. I can get into the reset menu, the thing is that it’s so out of focus and no matter what distance I can’t make out what it says.

Got a picture of what the menu should look like and tried to reset blindly but no cigar. It doesn’t seem to recognize my usb drive with the latest firmware according to the lights on the drive it doesn’t read it.

Also. Had some trouble finding the reset button, the manual says it’s right next to the usb when it’s actually on the right side of the device.

Happy for any tips and tricks. It’s a mean machine, just a bit displeased with all the broken promises of coming integration.

Hi, I’m writing here because I have exactly the same problem as Telboy, and I don’t 'know what to do :

I was doing a presentation, and suddenly, the image stopped… And then never came back : I can’t get any image / light now.
Now, I can see the little blue LED on the back what I put On , with the fans running, I can even ear the focus, but no image.

Can anyone help me ? Could it be software ? Is there a way to do a factory reset ? Or a hardware test ?

Thanks in advance for your reply,

Hi @Philips_Support_P ,
I do have also the same problem, could you also PM me the way to solve this ?
(Hope it solved the problem…)

Thanks !

Hi @Philips_Support_P could this also solve the Bluescreenofdeath that I experience on my PicoPix 3410?

I just get a bluescreen after the Philips logo has been shown.

I have tried disconnecting the battery to try and clear the eventual cash on the unit but did not do anything.
have tried restarting a bunch of times
holding the back button during startup.

but nothing has helped.

when plugging it in via USB I just get that windows cant recognize the device and nothing happens.

Seems like the unit wont boot properly and maybe I just need a tool that can interpet the device in this state and reload/flash the firmware.

hope you can help :slight_smile:

Can you send me details too please?

My picopix just has a blue screen regardless of what I do can I fix it with a PC of so how

Hello @Philips_Support_P
I have also the same problem in my projector , could you send me the way to solve this ?