Getting HDCP 2.2 error

Got this error while playing amazon prime content, wasn’t Philips screeneo supposed to have hdcp 2.2 support
Google Photos

Hello, which device from Amazon are you using ? Have you tried another HDMI port?

amazon firestick 4k max, I got this error only once when there was a crash when streaming(there is another discussion about it going on as well) and I restarted the projector and because my firestick was connected to external power source it started with the video directly instead of starting from home menu, so really don’t know what happened that caused this issue

so it happened only once?

Try these -

  1. Update VLC Media player
  2. Increase Cache Value
  3. Change Video Output Settings
  4. Disable Hardware-accelerated Decoding
  5. Change ‘Skip H.264 in-loop Deblocking Filter’ Setting
  6. Update Graphics Card Drivers
  7. Convert to compress 4K UHD videos
  8. Repair corrupt 4K UHD videos

yes, as of now

where are these settings??

Steps to change Video Output settings in VLC Player:

Click on Tools > Preferences> Video
Under Video Settings in Output, change Automatic to DirectX (DirectDraw) video output. You can also try OpenGL.
Click Save.
If you need help updating the driver I can suggest an article reference.

i think you are confused, I am not streaming through vlc player or PC, I am using amazon firestick and amazon prime video application which resulted in this error

Have you tried everything as I mentioned in the previous msg?

I have looked for a solution in a blog, But I can not share it because It will be considered spam. And the admin will block me.

Try to use a different cable.