HDR doesn't work with PS5

Hello,

I connect the PS5 to the video projector and cannot activate HDR with the last firmware (1.6.7), I have a message saying that the device does not support it.

I tested both of HDMI with the same message.

The HDMI cable used is the one given by Sony with the PS5.

But with the first firmware, the HDR worked because I had to adjust the hdr settings on the PS5.

1 Like

Yeah, i have the same issue with mine on windows, no more HDR but it worked on the original firmware version

1 Like

To get HDR10 working on my alexa fire tv with firmware 1.6.6 i had to use bluetooth audio output. With ARC enabled, it was not detected. I’m using HDMI 2.1 cables.

Update to firmware 1.6.9, the problem is still here.

Update to firmware 1.7.0, the problem is still here.

have you tried hdr with another device ? I acheived to make it work with my nvidia shield, but not on my pc

Please try setting sound output to ARC and then back to internal speaker, AUX or Bluetooth.

Explanation: When ARC is enabled, HDR is disabled because HDMI is dropped down to V1.4 for technical reasons. It’s possible that after the software upgrade, the HDMI EDID value became stale or corrupted. Setting sound output to ARC and back to internal speaker will cycle the HDMI EDID from v1.4 to v2.0 and might clear out any stale or corrupt settings.

Unfortunately it didn’t work.
I tried to change the sound output but I still have the problem.
I also tried restarting before switching back to ARC

I got the same issue. If I run Google TV (4k Chromecast) it supports 4k and also HDR, but with the PS5 it says the TV doesn’t support neither HDR nor 4k.

Tried connecting directly in both HDMI ports and toggled audio output.

Any update on this issue?

PS4 Pro… and issue here… 4k Firestick works no issue with HDR and 4K upscaling. PS4 Pro say ‘TV not HDR’ and I’ve gone through messing with ARC etc… what now… ?

You can try to use another HDCP 2.1 /4k HMDI cable.

With an another cable HDMI 2.0, PS5 shows this message “Device doesn’t support HDR”.

Are you planning to fix this issue in next software release?
If not, then customers should be clearly informed e.x. “HDR10 support* (*not available with ARC)”.

HDR doesn’t work in Windows 10 and 11 (firmware 1.7.0). Can it be fixed?

i told them for the windows incompatibility months ago they said it’s not normal
With the first firmwares i used to work :confused:
and indeed, HDR with androidTV (the only one i can make it work) does not work with ARC. That’s clearly something that should be changed, it’s a shame to have such small but annoying issues

How can I restore the old firmware?

I just tried with a ps5 yesterday and same issue too
@Philips_Support_P @Philips_Support_N could we have an update on this please ?