How to use this dysfunctional product?

Hey there, I simply can’t fathom how the device I have received can be considered useful. The remote only works when pointed directly at the unit within 1 metre, the wifi simply doesn’t work at all, even when placed next to a router it struggles to connect. On the rare occasion I can connect I try to update firmware to improve but it freezes at 98%.

I have resorted to using it as a projector for Apple TV (which is simply a dream UX compared to this), the only problem is the sound from the unit is horrible and I can’t change the volume with the remote or turn the off without doing it manually, feels very 1980’s.

I didn’t think a less user friendly device could be created these days, especially at such a high cost.

This has been a terrible experience and I don’t dare try and use the device for entertainment as it simply ends in frustration.

Am I alone in finding these features dysfunctional?

Indiegogo contribution #3422

1 Like

You need to pair your remote with Bluetooth connection. The IR connection is not useful at all.

I agree the wifi connect is horrible on 1.0.24 and 1.0.25 firmware. May be Philips can put up a direct download link of 1.0.26. So that every one can upgrade with using the USB. I haven’t had any connection problem since the latest firmware update.

1 Like

Please use these instructions to pair your AirRemote:

Please follow the instructions here for offline updating:

For 1.0.26 the link is this


You may not be alone in being unable to get certain features to work, but the product itself isn’t fundamentally flawed or dysfunctional. I’ve had mine for 6 weeks now and just love almost every aspect of it. Please try the suggestions above to get on back on track


Hi there, this link throws a 404 error, is there an updated link?

I don’t agree that IR is not useful. It’s very useful for turning on the projector and when sometimes bluetooth gets disconnected. And it can also be used to train other remotes so that you can use 3rd party ones that has more advanced buttons :wink:

1 Like

I updated to 1.0.26 but the wifi still doesn’t work, which for me renders this device useless. Not sure what else I can do…

1 Like

How is it not working? You can’t connect to your wifi or it disconnect or the connection isn’t stable?
In any case, you can try connecting to your wifi via the hidden menu.


About connectivity

I used to blame my old tv box attached to old projector for having shit wifi, so much that I had ethernet cable in the middle of the room to get internet connected. Then I changed provider and with it came a new router. - long story short - problem was in the router. I never doubted the router because my other devices had no issues, or at least I thought they had no issues. And the tv box was 2m away from the router and in the line of sight.

This does not say that you might have a faulty wifi but I would also, if possible, test with a different router because this is what fixed my problems. going to a friends’ house and trying it there is an option.

1 Like

Or even going to a Starbucks, McCafe, library, or any other place with WiFi. Or just ask your neighbor to use his WiFi for a while to test.

this post has all the step by step info as well as the up to date download link:
How to do offline software update?

Hmmm, every other device runs blisteringly fast off this router so the only faulty device in my apartment is the pico max.

It appears to cycle, connect then drop, I choose connect again and it drops.

True as that may be, have you actually tried my suggestions, and if so, what were the outcomes?

You’ve established the PPM doesn’t play nicely with your current router, aside from who’s to blame for that I think we need to identify if the issue is only with your router or with all routers. That will narrow it down to an internal problem either hardware or software related.

I think there are ways to generate WiFi logging files, that could help narrow things down further if you find a working WiFi connection to compare that to the non-working one you have now.

1 Like

I had a similar issue and poured through the forums only to realise that I had my wifi password wrong. The front end interface doesn’t provide any feedback indicating you have got the password wrong so I thought it was another issue. When you use the android back donor settings this menu is much clearer and tells you the password is wrong. Worth checking! (But not saying this is the solution, this thing is riddled with bugs! I feel your frustration!)