I find it difficult to navigate with touchpad, do you also?

I found it very difficult to navigate using the touchpad on the projector body. For example, in the homescreen, I cannot hide the quick access menu (when the pointer move to the top of the screen, the quick access menu show up) if I dont use the remote control to move the pointer downward.

Is it possible to just use the touchpad to navigate at all? say if i lose the remote. Is there a proper way to use the touchpad? It is not very responsive.

Think of it as a laptop touchpad, and practice using one and two fingers for pointer movement and scrolling motion respectively. Just like a laptop touchpad, the surface area doesn’t represent the whole screen surface, but rather is just an area to move your finger in. You’ll have to lift your finger(s) and reposition it/them to continue your motion.


I use it as laptop touchpad, but it just dont recognize my fingers easily. Not sure if this is a common problem.

Possible to make some improvements from the software side?

1 Like

I changed the title into a question regarding this, let’s see what kind of replies you get. If it’s a common occurrence, perhaps some sensitivity parameters could be tweaked or even made settable via a user interface.

1 Like

I have the exact issue you’re describing. The settings in the upper right are almost always selected, and I can’t scroll down to see all the apps. By using two fingers, I’ve been able to get it to scroll down about 5 times ever, and I’m sure I’ve tried over a hundred times now. It’s really unusable.

1 Like

Yeah the touchpad is a real pita to use.

Difficult to select and scroll. Obviously the image tends to move when you touch the projector, couldn’t get multi touch to work reliably.

It’s much worse than a laptop touchpad.

The airmote is ok (still like trying to navigate with a dead salmon but it works)

I have the same problem. Two fingers to scroll is usually non-responsive. Three fingers to move the highlight in the desired direction is slightly better.

Is anyone not having this issue? It would be very interesting if not, but I suspect it’s present in every unit, and people are just ignoring the touchpad and instead using the remote, or weary of reporting issues.

1 Like

I am not using the touchpad because I often have difficulty scrolling with two fingers.

I have the same, perhaps being able to configure ‘natural’ scrolling instead of the current upside/down would help. Also, I find the launcher hard to use, at random times does it switch from the app tiles to the settings, making it hard to navigate.

The launcher is optimized for arrow-key navigation. It works with mouse but I suggest using arrow keys.

1 Like

The topic of this thread is the touchpad. The remote works best with arrows, but I often find myself using the touchpad for some quick navigation. The launcher is not very user friendly when using the touchpad.


Yes, I tried to avoid using the touchpad as it would also throw off the focus and position of the PPM. In the end I got one of those OEM wireless keypads w/ a small trackpad that cost S$5 with a USB 2.4Ghz transmitter/receiver. huge QoL improvement in terms of using the PPM.

1 Like

The touchpad is really there as a backup so I wouldn’t suggest using it. Although it would have been better if there are arrow keys as well aside from the touchpad.


The touchpad navigation is easy I find once you know how it works.

To use it as a mouse / trackpad, move and tap with one finger.
To move it as a cursor, use three fingers
To enter / OK a choice, tap with two fingers
To scroll the whole screen, use three fingers

1 Like

Interesting, did not know this, where did you find this information ? I’ve been using two fingers for scrolling, which also seems to work, except that it scrolls ‘the wrong way’ if you know what I mean. On a Mac, scrolling down moves the screen down (and viewport up), on the PPM it’s the opposite.

What do you mean with ‘move it as a cursor’ ?

The other issue I have is more with the Launcher: For some reason whenever I use the touchpad it always tries to open the ‘Settings’ part (top half) of the launcher. It would be nice if the launcher would show the application tiles fullscreen, and only when the mouse-cursor clicks on the ‘cog’ should the settings panel open. Or at least make that configurable somehow.

Try it. You’ll see it moves one app at a time in the menu with every stroke.
I just tried some combinations, two finger scrolling doesn’t work as well as three finger scrolling.

Your issue with the settings is due to the way you first touch it, you’re inadvertently scrolling up I think.

1 Like

This is my experience with it too. Sometimes it works. Most times it doesn’t. Thus my frustration when using two finger scrolling.

So use three! :bulb:

trackpad sucks and also the IR receiver is put in a stupid position. the projector is above my head (bedroom). there is no way to make the remote work without stretching my arm up and pointing the remote to the projector. was is that hard to put 2 IR receivers on each side of the projector?