I Think My PPM Just Broke

Hi @PhilipsEngineering,

I was just watching Spiderman, and my PPM was glitching more than usual, going back to the app’s homepage (every 5-10 minutes), and the colours were off, more than usual. After a while, my remote wasn’t able to click and then within a minute of that there was nothing but a faint, clear, lit up screen, with no image whatsoever.

I thought, I would just reboot it, but the remote was unable to turn it off, and when I tried to turn it off directly on the PPM it didn’t do a thing. It is still like this as I write this. The fan is whirring away.

I had it plugged in the entire time. Not sure what to do. Any suggestions?

Thanks!

P.S. I wrote to Philips, but they probably won’t reply anytime soon, so I’m writing this here too,

EDIT: I’m currently draining the battery, so it will at least turn off that way.

Can you press the power button for 30 sec? It’ll power it off. Then charge it fully while it’s off before turning it back on.

I’m in Canada, so by the time you answered this, I had already drained the battery and went to bed.

I am currently recharging it, without it being turned on.

@PhilipsPrashant

I turned it on. The first thing that came up was a yellowy screen with a circle with an exclamation mark that said something like no connection. Then the Philips screen came on and it had pale pink and blue vertical lines that were about 10% of the screen wide each,

The home screen came up fine, but I played a Youtube video, and it paused for 30 seconds (disconnecting from the wifi I suspect) 7 times within a 4 minutes video timeframe. I tried doing a system optimization and it went from 72 to 100, but going back to the Youtube video it disconnected from the wifi again within 10 seconds.

For the record, there is nothing wrong with my wifi, both my phone and computer maintain a connection with no issues.

Should I try restoring the system?

Can you please restart and take a photo of this happening?

Hi @PhilipsEngineering, I will see if I can do it tonight when it’s dark. :slight_smile:
I received an email from the support team, so will fill out the trouble shooting for them. Do you want me to post it here as well?

Hello @Rhonda you can send the results to the support team, I will have access to it if it’s escalated. Don’t need to post here again but maybe other people can offer some insights if you do.

Hi @PhilipsEngineering,

I just took some pictures tonight and sent it in. I thought I’d post it here, just in case someone else experiences this. This is direct, before I angled it up onto the wall. They are in order of what happens before the home screen. It does go to the home screen, but wifi cuts out ever 30 seconds to a couple minutes or so. Any white background shows the vertical lines.

As a follow-up, I have been contacted by Philips/Screeneo, and my projector will be exchanged.

2 Likes

Any progress on this one? Did you get a replacement yet?

My situation is unique. They are waiting for me to return it, but I am in quarantine right now, so have not had anyone come to my place to pick it up. Therefore, they have not received a replacement.

As far as the return process, yes, they have been on it.

1 Like

My PPM is being picked up for return today. I haven’t used it since a couple updates ago, so I’m looking forward to all the improvements that will have been done by the time I get it back!

2 Likes

I just got my replacement last night. I’m excited to see how much has changed since March!

1 Like

Hello, I’m having the same exact problem. the pico max boots up then the light turns faint and nothing happens. HDMI still works but all other functions of the picomax doesn’t work. could someone contact me and help me resolve? it happened after I updated the firmware so i’m not sure if that caused any problem. thanks.

Hello @chickenbao this sounds like a known issue when applying the software update. You can first try to restart the projector. If this happens all the time, or very frequently, please follow Cable restore procedure to completely erase and reload the firmware.