Image adjustment and new software update not able to open prime or netflix


My projector have multiple issues now.

I’m not able to adjust my image. It just shows brightness as 50% and cannot be changed or updated

Now after upgrading the new software, i’m not able play amazon prime or netflix. It just spins and the apps crashes. The only thing now it works is with youtube.

I’m open for any call to discuss on this. I’m frustrated with this day by day. After every upgrade i’m loosing some functionality and making me unhappy.

Could you make a short video clip of what you’re experiencing?

Please try a factory reset to reset any corrupted settings back to defaults.

I tried to reset factory settings but no use. Now prime started working after upgrading the prime app but image i’m not able to change any of the image settings

Attached is the video of image settings which is not working

Video atached

Hi @sajjas36 the video isn’t there.

Meanwhile can you please go to Projector Settings > About > Video Chip Version and tell me what it is? Or maybe take a photo of that screen and upload here. Thanks.

Provided both video and image for chip version

1 Like

In this screen, use the left - right buttons on the remote to change setting you want to adjust, and up - down buttons to adjust the values. The mouse does not work on this screen.


Hi @sajjas36 yes as Ivo said, it’s a bug that the mouse doesn’t work for adjusting colors, we will fix it! Please use the arrow keys on the remote.

1 Like

Thank you by the way for providing the video, for it would’ve been more difficult for you to explain or for ya to understand what the issue was, now a moving picture spoke a thousand words!