My PPX4935 doesn't screen mirroring my iPhone as well I am having issue about licence

Hello everyone,

I just have purchased the projector and since I switch it on and set up the language etc I have connected it to wifi and tried to screen mirroring I had on the screen information about EZCast app that I have downloaded but in the same time received informations about updates there was like 5 of those until it reached version 1.25. I thought update comes first since it is a old model but I got it on sale… anyway after it got updated I straight away wanted to connect my iPhone on screen mirroring but then after it restarted I got a message on the screen saying: “Reach the limit number of licenses, please contact the software licensors to purchase again” and then it showed me “Machine code some random number Please waiting…” honestly I have no clue what to do. I tried to create a hotspotdirectly from the projector and mirror the iPhone doesn’t work reset my router doesn’t work it doesn’t find the device not iPhone iPad or Mac. once I have connected it to windows computer it showed me the files by the usb cable on the projector but windows computer doesn’t see it on the network either. I reach out to customer help they provided me with “latest software but actually its even older version that one installed” and on the web I have seen a 1.30 but I can not instal it on the projector as it says that it will instal updates automatically when connected to wifi… does anyone had similar issues or can try to help me out.

@PhilipsEngineering we have an issue of key here

Hi @Karol_Weglicki please install the V1.30 firmware by downloading it from the Philips website, and installing it offline (refer to the user manual for instructions).

In parallel, we are working to resolve the keys issue together with our supplier.

I have the exact same problem…

i have reached out to philips but no one is helping and the device is fully updated

@PhilipsEngineering could you check please? @Karol_Weglicki be careful, screen mirroring wont work with DRM protected content such as Netflix. You will need the official Apple Digital AV Adapter with an HDMI cable.

Sorry for asking a semi related question because I can’t post new topics as new users.

Does PicoPix Nano support Android Miracast DRM contents such as video from Netflix or Amazon Prime? I am interested to buy.

I am aware of that. It still doesn’t work

I also have this issue, I’m stuck on version 1.25, additionally it won’t recognize the new firmware 1.3, so updating to that is also not possible.