Netflix has stopped working

Same issue here. I also tried the same steps as Spyro and dmircea without success. Would be happy to provide further info if needed.

Any updates on this, I also have the same problem. Tried resetting device and still cannot login. Tried dozens of times, each time double checking password and email to make sure.

Hello, indeed it seems that this apk version is not working anymore as netflix changed their log in policies. We are now trying a new APK and will send it by FOTA as soon as we have proper results

1 Like

Any news on this?
After a factory reset I am now having these issues also.

Hello, please proceed to the new version.
You can uninstall the previous version and the new one will appear on the MORE APPS section

I’m afraid that’s not the case.
Clean factory reset
Uninstall Netflix
Nothing in more apps

Same here. Netflix app is logged out. Can’t log in again. Deinstalled but no app shows up in the “more apps” tab.

I finally got Netflix to download and install, but it opens up to mobile portrait mode and it’s ridiculously difficult to try and type in the password since it’s not displaying as intended, in landscape on the projector. I also just upgraded firmware to latest version.

Hello, you can also install the ROTATION app in order to fit the app to the projector. On our side we are still looking for a solution

Thanks support team. :slight_smile:

Is there a specific Rotation App that is on Aptoid TV on the PicoPix Max home menu that I should use? I have tried several rotation apps and have found no rotation app yet that can actually make Netflix viewable in landscape view on my PicoPix Max.