PPX3410 - blue screen after Phillips logo

I have a PicoPix 3410. I really like this little projector but it suddenly stopped working. I can switch it on with remote then I see the Phillips logo. Then logo disappears and In only see a blue screen, cannot get into the menu. Is there a way to fix this? Even if we need to update firmware or similar I am happy to do it just need some guidance. I hope it can be fixed. :frowning:

Hello,

Unfortunately this product is quite old (2013) and we don’t support it. I think the issue is not software but hardware. What is happening if you connect something on the HDMI port?

Hi,

Thank you for replying back to me. Once I switch it on I can hear the fan running, then I see the Phillips logo nice and clear.

Then this blue screen appears with some kind of ‘ant war’ on it and I see white and blue squares at the very bottom of screen exactly like this:

A few people posted the same issue on Reddit: https://www.reddit.com/r/projectors/comments/j7r6y7/picopix_ppx3410_not_booting_into_menu/

And screen slightly blinks after around every 2 seconds, like it stuck in a loop or something.

If I attach a USB drive it’s powering up, no difference if I attach something to HDMI port.

Is there any way to hard reset these machines without being in the menu? I understand that you are not supporting this machine anymore. However, and ideas or help would be much appreciated.

I see. Seems the Linux OS is not booting.
I’m sorry to say that even if we can technically repair it, it will be easier, faster and cheaper to purchase a new one. Depending where you are, we are currently running some discount on our new projectors

Thank you for your reply. I am taking it as a personal challenge and I really would like to save this little machine from dropping it to bin. I would be able to replace the main board myself if I can source a replacement. Is this something you can sell/send to me? I understand that there is no warranty if I do it myself. I am happy to pay for part and postage. I live in Hungary (EU).

1 Like

Hello everybody. After like 10 hours of not givig up today I managed to FIX IT!!!

In order to change the firmware I managed to find the newest firmware (2020) for the ppx 3414/F7 and I hoped that it worked for my ppx 3410 since they looked exactly the same (I checked both user manuals).

Then I saved it into a SD card and I put it into the projector, connected to the charger.

Then I started it and once I got the blue screen, I plugged on and off the hdmi cable a couple of times (I had the projector plugged to my laptop via hdmi) and turned on and of a few times until OMG it showed the main menu!!

I was tempted to keep using this method forever (and not download the newest firmware, since it scared me a bit), but I decided to go to SETTINGS/MAINTENANCE and ask to install the new firmware. After a couple of minutes, the new was installed.

I turned off and on and… IT WORKS!! The white

I am sooo happy! I hope this works for everybody.

I did not trust the firmware I found in strange sites. Mine is from official philips website. Find it here: Asistencia para PicoPix Proyector de bolsillo PPX3414/EU | Philips at the bottom of the page. Yo need to unzip it and leave save into an SD card, on the root. it has to be formatted FAT 16 or FAT 32

Good luck!!!

1 Like

Hello Martacume, thanks for sharing the good news with us. I followed all steps you mentioned but unforunately mine is not going to come back to life. I formatted the SD card to FAT16. Unzipped and copied the bin file to the card. I also tried to copy the zip file too… It’s loading up the Phillips logo, then I got to the blue screen with white squares at the bottom, then they go so I only see the blue screen that blinks after every 2 seconds. No matter if I plug the HDMI in or out or if I swich it off and on again, I can’t get through the blue screen. :frowning:

Hi, so sorry to hear that. You need to get to the main menu for one time only, to force the change of firnware… I guess in my case it was just luck.
For me sometimes it was just blue sometimes bue with BW sqares at the bottom. The time I got to see the menu the screen was blue and then I unplugged and plugged several times and bingo…
Sorry to hear it did not work for you.

It must be a recurring problem because I see in the newest models, if you insert an SD it just runs the system from the SD. Just like the floppies we used to have for emergencies when I was young…