Problem with mirroring Apple product via Airplay/HDMI

I have some problems with my PPM

  1. I tried to use AirPlay for Mirroring of iPhone/iPad AppleTV but not working. Only black screen.
  2. Even I tried HDMI cable directly connect my AppleTV to PPM. Only picture but no sound. Speaker not working via Bluetooth connection

This means PPM is totally useless for apple product, as can’t enjoy any video streaming

Bluetooth generally does not work when ppms input is hdmi.
When I connect my iPad via hdmi, both the internal speaker of the ppm and its aux output work fine.

I can Airplay from iPhone X, iPad Pro and MacBook Air to PPMax without issues.

Airplay generally has no problem, but it doesn’t work with appleTV app. Only black screen when I use iPhone/iPad mirroring AppleTV app

U don’t have this problem?

DRM content is not supported. I think it has been discussed few times in this forum. I can’t remember the technical reasons. Do a search for “airplay drm”.

1 Like

Thank you.

1 Like

Hi @Kaikong, when using an Apple TV, please pair your Bluetooth speakers directly to the Apple TV. Doing so will ensure proper delay compensation so that audio and video are in sync. PicoPix Max does not support transmitting HDMI audio over Bluetooth.

I have also a problem with iphone, when I click on screen mirroring so nothing happen. I get only the sound through the picopix and only for 2 seconds and it is disconnected after that. I tried to restart and I updated the software with last update today but nothing help.

How about airplay Apple tv app from iPhone/iPad ?

You need to be more clear and precise on what content you’re trying to screen mirror, what app web page etc, when you say you only get the sound for 2 seconds, what video was that sound from? YouTube? home video? Netflix?

When I click on screen mirroring, the screen freeze immediately, and if I already running a video from a website or from my home library so the same happens and the screen freezes but the sound of the video from out from the projector for 2 seconds.

In Hong Kong, playing HMVOD via AirPlay is fine, NowPlayer does not work (now tv blocked this long time ago), Can’t play now tv content from the stock browser. As playing HBO Go on my smart tv via AirPlay is possible, but takes long time for downloading the whole movie content before starting to play, it might be possible for PPX, but it takes so long that I don’t bother to try. Really want to install HBO Go on PPX. YouTube is ok.
All tests via iPhone.

Hey all.

Has anyone experienced the issue of ‘Airplaying’ from the Apple TV App on iPhone to the Picopix Max and getting the message (on the Apple TV app) saying ‘There’s a problem loading this content’, and the video not playing?

Cheers.

1 Like

I have the same problem with airplay

  1. Airplay works with Netflix but with Disney + I get sound but no picture and with Apple TV It won’t load
  2. If I connect with HDMI Netflix still works but Apple TV has picture but no sound.

Any idea how I can solve these issue?

Thank you

When I connect my 1st gen iPad Pro via Airplay, using the Apple TV app, the screen is just black. On my iPad, it shows that the movie is playing, but the the Picopix Max screen is just black. It displays the play/pause menu at the bottom and thats it. I tried restarting the Airplay app, turning Airplay off then back on. I made sure to update the software as well. No luck. The only way I’ve been able to get this to work with my iPad is to use an adaptor, connect via HDMI, then use a bluetooth speaker for audio (connected to iPad).

It probably won’t work, because Apple is very restrictive with what they allow to be streamed. Most DRM-protected content seem to be allowed to be streamed only to Apple TV’s. I would say your best bet is the adaptor.

Hi,

When trying to stream movies from Apple TV app to Pico (latest software version) two things happen:

  1. Strange subtitles are shown before the stream begins (some in Spanish?). These are not related to the movie, IMO its pico internal software issue

  2. Nothing is playing, time pass, I can forward movie etc but no sound or screen is shown.

As I’ve tried three options to play movie a non of them works (Netflix also), I’m honestly quite disappointed after waiting for 7mo for this projector

Airplay from Apple TV app does not work for me either. (AirPlay photos on my phone works fine). Also, contrary to what @PhilipsNono says, Apple TV does not work through the web browser