Projector not booting. Been calling support and no one is picking up and created a ticket here for a month with no reply

My projector doesn’t boot into the OS. It shows the logo then the light would go dim. I have tried the sugggestion by the support person in trying to force flash the firmware but it doesn’t work. I have also called support many times and it said no support agent is available. I have email support multiple times with no reply. I have also wrote back to the original support person here that told me to flash the firmware (i had to buy an usb cable to do so) and they don’t reply. HELP!!!

any update? I still haven’t heard from anyone and tried calling philips many many times and they are always busy and drop my call.

What’s your ticket number?

@chickenbao I have exactly the same problem, but no reply from support.
I is deeply frustrating.
I am sure this can be solved without sending the unit back for repair, but no help is available.
The link they asked me to follow is broken, so it really makes no sence to me, but when I ask for a working link - no reply :disappointed: