Projector picture froze, sound continued to play, now stuck on a green pixelated screen

My name is Octavio Zuniga. I just got my new PicoMax projector in late December 2019. I have been having projector freezing/picture freezing issues, at random. I updated the firmware to the latest version without any issue but the problem persisted. The video would freeze but audio would continue to play. The only way I was able to unfreeze the projector was by pressing and holding down the power button on the remote or projector. The screen would then go black and then I would press the power button to power back on.

I did a factory reset in hopes of clearing up the issue but the problem persisted.

Shortly after that, the projector would freeze at the boot screen with the circle and Philips logo distorted and frozen and it has now gotten to the point where I just get a green pixelated screen when I power it on.

I have emailed your with pictures to document my problems since January 3, 2020 with no response other than the automated message that it was received. I am getting quite upset at the lack of response. I fear a defective projector and would like to have it exchanged for a new unit.

My projectors serial number is: QS1912P620A00060

Thanks in advance for any advice and help you can provide.

Octavio Zuniga


Hi @Tavio I believe this is a defective display. As far as I know your email to bugreport@ has been received, but they’re waiting for Logistics team to finalize how we can exchange your projector in the simplest way possible. Expect that in the next few days they’ll get in touch with you to organize the return. Thanks for being patient.

Definitely some image processing failure (post V56). It’s always interesting to see these failure modes, thanks for sharing the high-res pictures @Tavio and I hope you get at replacement sorted soon!

@Hobbes I think we can confirm that the splash screen definitely is 960x540, no actuator action going on there! And the color noise is in a nice 120x135 array. Coincidence? I think not, 960/8=120 and 540/4=135.

I’m seeing this from my phone so I am not entirely sure of what I see.
I would guess the first image to be the dlp splash screen, no pixel shifting, so that would be generated by the dlpc using its flash, and seems to have no defects. The figure below looks like a spinner, though? Is it animated? That would be odd for the “hardware” splash.
The second image looks at an higher resolution or a different antialiasing . Perhaps they replace the “hardware” splash with one generated by the v56, or the application processor during boot? If so the problem there could be the v56, or even the fpga.
The third is definitely a cool failure mode, it’s not jus noise, it has a banding pattern in the lower half :wink:

There’s always the possibility that some of what is seen in the pictures are artifacts from the camera as well. I’ll have to shoot some high framerate video when my PPM arrives! One of my cameras can do 960fps at 1080p at least, so there should be plenty of interesting things to see!

1 Like

Any exposure time with less than 1/60s is going to show only partial resolution, and shorter times would even mess with the color balance.

1 Like

I’ve done some investigating now that I’ve had the unit for some time. The white Philips splash has to be generated by the RK SoC, not the DLPC (the splash from the DLPC itself should be more or less instant after power-on). Also I’ve gotten a Rockchip Kernel logo showing up very briefly just before the white Philips Splash as well. I guess I have to splice in a splash of my own into the DLPC flash :slight_smile: but I haven’t scoped out how fast PROJ_ON is pulled high after the power button has been pressed yet. Looking at the DLPC System Power-Up and Power-Down Sequence it seems like the FPGA is spending over 2 seconds booting, during that time we should be able to have the DLPC splash if we want to (most definitely without any pixel shifting as the actuator is controlled by the FPGA).


I’ve also been plagued by freeze-ups of the display since I’ve received my PPM. I’ve continued to hope firmware updates will help. But really no. Like the OP, have tried factory reset. Have tried disabling auto-keystone and auto-focus. No avail.

The freezes happen at all different times. Most of the time, just getting successfully to the launcher and having the NTP sync to update the clock is a challenge. If I manage to get past that, It’ll freeze during display.

When it freezes, the display just freezes on frame. From a Menu or the while Philips splash, sometimes I get “low rez block pixels”. During playback from an app, the image on display just freezes. Audio continues. The projector is responsive to controls on the AirMote, but the display just doesn’t update.

Tonight on latest available firmware, I couldn’t get through one entire Looney Tune cartoon on HBO Max. I couldn’t get past 3 minutes on Netflix (the version included with the firmware).

There’s no way I can actually use this projector to watch a program alone, much less with guests over.

1 Like

Dear @Philips_Support_3 am experiencing the same problems - the image freezes while audio continues.

My serial number is QS1912P620E09402
Is the solution to the problem known yet?
Will this work with an upcoming update or do need to exchange my projector?


Dear @Philips_Support_P,

I’m experiencing the same problem as other customers below.


  • The frozen screen appears quickly after starting up the projector
  • The screen is frozen but the audio continue.
  • no specific sequence allow to frozen the screen.

My projector ID is QS1912P620E09305
Need help please.


Is this a permanent issue now or will you occasionally be able to get a good picture when powering the projector on Romain?

I have noticed that some of the parts close to the DLP FPGA can get quite warm and it’s possible that there are some marginal solder joints in that area. But on the other hand at least one unit survived a drop from quite the height and STILL powers on with good video (then shutting down for some other reason), so it’s not a universal issue. I assume these pixelation issues all should be covered under warranty (and by now I would definitely hope that the swap stock is in place.

I had the issue that the picture froze after 30-60 minutes and the audio continues. I wrote to the support who recommended a factory reset. This solved the issues for me.

Hello, two weeks ago I bought a Screeneo S4 SCN450/INT in Belgium.

Have daily picture freezes (rate: +/- every 4 hours). Exactly as describes in the posts above.

Did a factory reset + upgrade but to no avail.

Should I return the product or is there a fix?

  • Also colour presets are horrible - is this normal?

Happy 2021.