Remote is not remote 🙃

Dear team, and fellow PicoPicers,

I’m having problems with the remote of the picopic max. In theorie the “remote” is working, but only on a very short distance of about 1 meter and straight behind the projector.

-software pico-pic max is up to date.

-software apps are up to date.

-battery refreshed (several attempts, even bought brand new once’s valid until 01/2031).

-unpaired/disconnect the remote and shutdown the projector. Restarted the projector, check if the connection was dropped :white_check_mark: and reinstalled /paired the remote again (used keyboard for menu movement), no improvement.

Now there are two possibilities in my believe,… the receiver in the projector, or the transmitter in the remote is not working properly. Please advice…


Greetings, Joop Terwijn

Who know if the kickstarter deliveries still are under warranty (or not). Apparently I have a “dead” remote( Bluetooth part)…
If not does any one know the part number for the Philips remote? And any idea where I can order one.

Same/similar problem here since this week. Infrared is still working on the airmote, but Bluetooth is not though…

First I thought it was still connected and paired (ws still visible in Bluetooth menu as connected/paired. But after unpairing and shutdown Bluetooth option followed by restart PicoPic. Then re-enable Bluetooth I could not get the remote back in Bluetooth in anyway I tried. I reached out to Philips, they reverted to a manual page about connecting, well that was not helpful. I don’t know if there still is warranty, basically I said where can I buy one! Because the warranty replacement would take for ever… waiting on a answer…

Have you tried changing the batteries, I know it is a stupid question, but I had similar behaviour and it got fixed with set of fresh batteries. Even though the remove showed red led the batteries were not good enough to keep things running in general.

Yep, as I said in the beginning, that was the first. Even bought a brand new pack (valid until 01/2031) checked the contacts for possible corrosion.
Thanks for asking, but that field was covered.

My learning is need to hold ok v- buttons long time . Hold it until u see red blink . I trIed couple of times , finally it worked .

The remote is quick to respond with the flashing red LED (sound +OK buttons) that’s not the problem. The fact that is is not registered by the projector and though not appearing in the recognized available Bluetooth devices is the problem. So apparently I do not have a Bluetooth signal coming from my remote any more.
I checked if I see the Bluetooth signal of the remote on other receiving devices, for instance my iPad or android mobile (just to verify if there is a Bluetooth signal) non of them registered a signal ind the flashing LED period. So there is no signal, the remote is ‘Bluetooth dead’

For now I found a solution, I the hidden supply (everything you own but don’t know any more :crazy_face:) I found a wireless keyboard/mouse with a little dongle. The projector accepted the dongle so now life is easy again. The mouse pointer works (even the scroll-wheel!).
Now finding time to digg into the remote electronics and sea if I can bring it back to life.