Remote partially working

Hi,

While trying my projector, in dark room, I found out that some buttons on the remote are not working. I’ve tried to change batteries but issue is still here.

When I press these buttons, the upper LED is blinking 5 times and action is performed on projector:

  • POWER
  • CURSOR
  • LEFT
  • UP
  • OK
  • MENU
  • BACK
  • VOLUME +

In addition, I’ve also checked with my phone camera, the IR LED is on with above buttons.

When I press these buttons, no LED blinking and no action on the projector:

  • DOWN
  • RIGHT
  • HOME
  • FOCUS
  • VOLUME -

With my phone camera, IR LED is not lighting

Because of “VOLUME -” button not working, i’m not able to pair the remote.

Is it a know issue on some remotes? How to get a new remote?

Thanks

Regards,

Theo BORIE

Hello,

Is there anybody from Philips able to help me change the remote?

Thanks

Theo

If you don’t have a ticket already, please open one by sending an email to support@screeneo.com with your issue, you can copy and paste the first post into your email.

Hi @theoborie additionally, I would like to know if you’ve paired the remote with your projector using Bluetooth? If yes, do the buttons still not function after pairing?

1 Like

Is there another way to pair the AirMote?

1 Like

Unfortunately no. In this case please contact Support and ask for a replacement remote control. You won’t need to send back the whole projector.

1 Like

Hi Philips,

My remote is not working suddenly now. I changed the battery but it still doesnt work. No cursor and no movement. I tried the touchpad on the ppm and it moves so i think its the remote issue.

How do i go about for this situation?

Same pb for me with the remote:

No possible to pair by bluetooth: the remote is not reconized

It only works for focus and off mode. Nothing else.

what can i do ? Change the remote?

Mine doesn’t do anything anymore, three weeks after I received the projector and everthing worked fine.

I wrote to support on September 1st, got no answer, wrote again and again, in October I got a mail to look for help here in the forum! :frowning:

Of course I had done that before and tried all I could find here (take out batteries for longer than 30 seconds, check with smartphone camera, hold certain buttons together for a few seconds, replace batteries).
Nothing helped, it is just plain broken.
If you tried, you know the projector is near to useless without the remote, so I am very disappointed by Philips and their support.

@PhilipsEngineering

Hi Rabe,
Thank you for sharing your bad experience. I will try to contact the support. Where can i get in touch with them? I agree, it’s nearly impossible to use the device without remote. What a shame. I’m so disapointed.

Thank you!
The address they promote is support@screeneo.com

I have the same problem, the only thing the remote is good for is to turn the projector on and off. I will write to the customer care. I tried everything else.

@PhilipsEngineering @PhilipsIvo