Screen mirroring problem with Samsung S9

Hi, Thought I would post here as having screen mirroring issue with my newly received PicoPix max! Great little machine, but unable to screen mirror using my Samsung S9 (One UI 2.0). When I go to settings/mirror/Android on my picopix max, it comes up with connecting and then connected in top right corner. The Picopix max screen does not change though and does not display my phone. My phone, through smartview, under screen mirror states connecting and remains on that.
I press the back button to get out and then notice that the picopix max disconnects from the Wifi as the top right wifi symbol goes blank. I have to power off and restart the picopix to get the wifi going again.
Can anyone help out as I would really like to attempt to mirror my phone’s screen to display videos and family photos (one of the main reasons I purchased the projector).
Thanks

Could you please try installing “AirServer Connect” app on your phone and use that to mirror to the Apple mirroring option on the projector? I think it’s a bit more stable. Both your phone and projector should be on the same WiFi network for this to work.

Thanks #PhillipsPrashant! That did work to show pictures (which the family are loving!). The videos are a bit pixelly though, but at least that is an improvement.
The mirroring did drop out a few times, but unsure if that is just a stable connection issue or an app issue?
I thank you very much for the support though!

2 Likes

Try to use a 5GHz wifi network if possible, it should improve performance. Also, I’m not sure if Samsung phones support Google Cast, but you can try that too. I think you have to have Google Home app installed for this.

The “Apple” mirroring feature supports Google Cast and DLNA in addition to AirPlay. Currently you’re using AirPlay so if any of the other 2 options work you can try those.

The 4th mirroring option is Miracast (the option labeled “Android” in the projector settings) which is the least stable out of all options.

3 Likes

Thanks PhillipsPrashant. I do have google cast but found that playing video through googlecast results in frozen picture and non following audio. But I wasn’t using 5GHz wifi. Will try that next.

Just tried 5GHz google casting. Works smoothly! Thanks

3 Likes

Changed the router settings to 5ghz?

#imdevu, my router is dual band, so has both 2.4GHz and 5GHz frequencies available. I usually log on to WiFi using 2.4GHz as find I get better stable connection throughout our whole house as the 5GHz is great only when within 10-15m from the router. Hope that helps

1 Like

Thanks for the update. This helps.

1 Like