Screeneo 1550 startup

Hi, my screeneo 1550 is only showing the logo when turning it on.

Please advies what to do.
I read somewhere there is a piece of program available to erease and reprogram the internal memory…?

So, i contacted Philips Projector service line, and they cannot help me. They point me to a few different repairers. I contacted them and they cannot repair a Screeneo.

Then i contacted Sagemcom and they point me to X-GEM:
" Sagemcom Documents’ Retail business was transferred to X-GEM as from 1 August 2015 , as of that date, all of Sagemcom Documents’ after-sales service commitments relating to these products have been assumed by the company X-GEM. Therefore, your request should have been addressed to X-GEM, its agents (mandataires) or successors."

So now it contacted X-GEM, but stil no answer.

I thin if they make a Screeneo which has a 30.000 hour lamp life span, i should last longer than only 3 years.

How to get this Screeneo into Flash mode? or somekind of bootmode to put new firmware on it.
It seems to me thats the problem, because the projector starts up shows the Philips logo and then it will stay on, but the screen stays empty…

Please help!

Hello, the XGEM company doesn’t exist anymore.
We are going to check with our engineers how to flash again the software.

Any info?

I have got exactly the same issue. Projector powers up, logo is displayed and then nothing is getting loaded.
I have tried to perform a firmware update through SD-card, but it didn’t work, still same thing, logo and then nothing. I really hope to find a solution! Thank you in advance!

Hallo again! Any news on this? Is there a way to flash the software?

Hello I hope you will find solution. My projector can’t load also

Write estimate date then we can expect answer, please


After some research it seems that the machine cannot be repaired.
The Screeneo HDP1550 was a 2014 device that we don’t support anymore.

It is so strange because in November 2020 was firmware update.

We didn’t release any software since a long long time. I don’t even recognize this website.

Hi everbody! My Screeneo has the same issue. Will get stuck on the logo when turning on. Did anyone find a solution for this yet? Thanks!

I there, I had the same issue…no possibility to go on the menu, screen was stuck on philips logo loading and loading.
I found this video on youtube , in the last 10 min, the guy tries several key combination (shut down the screeneo > press all keys (the 8 keys next to the on/off button) together and hold while starting the projector…) then somehow appears a drop down menu with the possibility to reset the projector…
I had to try several times with or without bootable sd card (before starting, I downloaded the last firmware with the hope that the projector would boot on it automatically…but never happened!)
But at the end, thanks to the trick in the video, it worked perfectly and I could apply a factory reset!
Good luck🤞