Short review and DRM issues

Hi there! I finally received my PPM last Tuesday and I’ve been using it intensively during these days. So far, I’m quite satisfied with the device. I started with software version 1.0.27 already, so I assume there were many fixed bugs that I’ve read about in this forum before receiving my PPM.

I’m projecting on a wall (no screen yet) which is not pure white (rather yellowish, but quite light). I’m easily getting a +100 inches display and, under no external light, brightness is quite decent. At the hardware level, I think everything is working quite well (I’ve not tried HDMI or USB-C yet). If any, I would point out two issues, which are not particularly severe:

  • The PPM fans are quite noisy. When setting the energy-saving image mode then fan noise is less loud, but still significant. I’m not sure fans are adjusting their speed to current device temperature. I mean, it’s not the same using the device in a warm room than in a cold one, is it? When I touch the projector, it does not seem to be quite warm. Maybe fan speed could be adjusted?
  • The tripod is not quite good, it feels like cheap. I would probably consider acquiring a different one.

At the software level, there are still things to be improved, although the experience is not as bad as some people described earlier in the forum. Right now navigation is fluent. I’ve been able to watch Netflix, Disney+, Amazon and Popcorn Time with not many issues. However, there are some things that do not look quite well, and others that surely needs to be improved. For example:

  • Thumbnails in this hacked Netflix app looks like very low-resolution. I mean, I can see videos fine, but when navigating through the menus, thumbnails for movies and series look horrible.
  • Navigation in Netflix is weird… it improves with the AirMote pointer, but it should go fine using the keys, shouldn’t it?
  • For unknown reasons, Disney+ sometimes crashes on exit. I mean, when watching some content and pressing “back” on the AirMote, the projector crashes and restarts.
  • There seems to be some problems with DRM-ed content, I don’t know if this has to do with GMS or not. For example, I installed the Movistar+ app (one of Spanish main Internet & TV providers). It can play trailers and ads with no problems, but content is not shown, rather a black screen. I’ve read other people in this forum describing similar issues with other apps. Can this be fixed in some way?

In summary, despite these things to be improved, I’m quite happy with the projector so far. I think it is worth waiting the delivery! :slight_smile:



Leaving you with this screen:

What I found works is to pause the video, then hit the back button.

I think it’s dependent of the movie quality / bit rate / codec. I’ve been able to consistently replicate the crashing behavior by playing this series’ episode:

1 Like

I don’t see that screen at all. What I see is the screen (the video) freezing for some seconds and then the project restarts immediately after. Your suggestion to pause the video and then go back seems to work fine, at least the few times I’ve tried. And yes, I agree that it only happens with some contents.

Any idea that could make the DRM-ed content from other apps? Or it all boils down to GMS?

1 Like

No lo se Alejandro, no tengo idea de que pueda ser.

1 Like

Hola, ¿alguna novedad con los errores en la app de Movistar +?Gracias.

Hello, Any News with this DRM-ed? Thanks

I don’t have any news. I’ve not tried again, but I don’t think any PPM update has changed this issue.

The problem still persists. I’ve downloaded the last update and Movistar+ still doesn’t work.
I’ve tried using miracast from my phone and it also doesn’t work.

Same here… no way to make Movistar+ app work.

Is a copyright problem on AirPlay?

Movistar+ still doesn’t work :frowning:

Same problem here regarding potential DRM issue.

For what it’s worth, this version works.
The catch is that It is not the Android TV version but the regular Android version. Besides, this version (6.0.7) is not the last one available (6.3.0 at the moment, which doesn’t start at all)

1 Like

Does 6.0.7 work??? Cojonudo. I’ll try later.

1 Like

YES!!! It works.

This version is a pain to navigate but at least it’s working

Thanks for the info!

1 Like