Unable to turn on PPM via remote

I Can’t seem to turn PPM ON via the remote. Even I tried pointing the remote so close to PPM. Remote battery is not dead. This doesn’t happen all the time but most of the time it does. The issue seems to have started after updating to 1.0.29 and the recent software update. @PhilipsSupport

Are you pointing the LED on the remote straight at the back of the PPM? Turning the PPM on via remote is done by infra-red light, so there needs to be a line of sight for it to work.

1 Like

@djupsjob yes I pointed it straight to the receiver near the power button at the back. Also brought the remote so close to PPM. But doesn’t work

2 Likes

Hey I had the same problem what I did took batteries out put them back in it worked for me

Also the remote is not good very poor you have to be really close the the projector crazy they really need to fix this problem

Regards

Keep safe

Did you pair the remote via bluetooth? How to pair the AirMote – Philips Projection

Even so, I’m able to control my PPM from across the room without pointing in the exact direction of the PPM.

In that case, you can check that your remote is working by using the camera on your phone. Start the camera, point the remote at it and press the power button. If the remote works as it should, you should see it light up in the camera. Like this: https://youtu.be/vsSZ3IMUQYE

3 Likes

Hi @Vish, are you pressing the power button on the remote for 1-2 seconds?

1 Like

Try disconnecting your airmote from bluetooth and check if your remote does work via IR. Perhaps it is defective.

Also IR’s signal power depends on the battery level so if you’re using a good and new battery, your remote should work even with long distance or it will even work bouncing the signal from walls.

1 Like

@djupsjob The remote works at times. But it plays up randomly.

1 Like

@PhilipsEngineering Do I have to press and hold the power button yo turn on PPM? I think I have seen it turn on just by pressing the button

If you can’t get it to consistently light up in the phone camera when you press the power button, and have tried with fresh batteries, I’m out of ideas. Over to @PhilipsEngineering.

1 Like

Yes I can see the IR light flickering through the phone camera

2 Likes

And it always lights up when you press the button? That’s the expected behaviour, isn’t it? At least we then know that the remote works.

1 Like

Hi @Vish perhaps hold it just for a second or two, similar to the power button on the projector itself.

If that still doesn’t work, it could be a faulty remote control.

  • Q1: Can you power off the projector using the remote?
  • Q2: If you disconnect it from the projector (in Bluetooth settings), do all the other keys still work?
1 Like

Hey thanks for your help all sorted now running remote on bluetooth works great thanks

1 Like

@PhilipsEngineering - Yes I am able to power off via the remote. And also all the buttons on the remote work fine after disconnecting the airmote via bluetooth.

Its very random. But I see it playing up almost every day.

1 Like

can you confirm that switching on should be possible via bluetooth? back of my ppm is at a wall so for using it via infrared i had to move the ppm every time …

I can confirm that Bluetooth cannot switch on the PPMax. Only IR can switch on the PPMax.

1 Like

thanks. is it planned to change that? always have to reconfigure the ppm after moving it :frowning:

You can get an IR repeater, or a simple mirror behind the PPX perhaps?