USB-C video input stopped working, shows NO SIGNAL screen

I have been using my projector with both my MacBook Pro and my Switch. After a few months of no usage I tried to connect again, and it’s no longer receiving signal via USB-C:

  • I get the blue and green led light up and a yellow screen saying NO SIGNAL
  • both devices register the projector - the MacBook shows the second screen, the Switch screen goes black just like it should when I connect an external screen
  • both devices work with other USB-C displays and with all the cables with which I tried
  • both devices can output signal to the PPX via HDMI
  • all three devices are fully charged
  • all three devices are fully up to date with firmware and software - I have just done a factory reset on the PicoPix Max and updated its firmware to the latest one

Not sure where else to try and find the problem, any input would be greatly appreciated.

Many thanks

Hello, may I know which USB-C port you are using, also, which USB-C cable ? Are you using the one provided in the box ?

I am using multiple different USB-C cables, including the one supplied. I am using the USB-C port labeled “(VIDEO)” to connect to the devices and the one labeled “(POWER)” to connect to the charger.

*edit: also, I have actually been using a third party cable all this time with no issues, so I think it’s safe to rule that out.

Any thoughts on my response please?