Video on USB C not working

I am trying casting video content from my Galaxy Note 9 to the PPM through the USB C (suplied) cable.
Unfortunately the PPM doesn’t detect anything and my phone says “problems with the HDMI cable”.
I checked the troubleshooting guide, but nothing solves it.
Unfortunately I don’t own any other USB C sources to test…

1 Like

Hello @Vito_Darpaki have you connected it to the USB-C VIDEO port on the projector? Does the LED on the projector turn green?

1 Like

yes, Video port, I will let you know about the led color but I think the input device was not recognized.

The light doesn’t turn green and the phone keeps saying to check the hdmi cable.
I am not 100% sure that galaxy note 9 can stream video through usbc, maybe I need an hdmi adapter?
I am trying to watch my favorite show, but usbc doesn’t work, Firefox on the ppm cannot process the video, and chrome casting has strong audio stutter…

Have the same while connecting flash drive into USB-C.
LED turns green but there is “no signal” in the yellow background.
Any idea?

A flash drive will not work when inserted in the USB-C video port or the USB-C power port, plug flash drives into the USB-A port.

The input selector will switch to USB-C video even with just a cable inserted it seems (I would have expected it to only switch after alt-mode negotiations have completed).

Thanks for an explanation Werner!

1 Like

So does anyone else have this problem? Is @Philips_Support_P looking into it?

Hi @Vito_Darpaki,

  • does your phone output usb-c video to another device?
  • does any other usb-c device successfully output video to your PicoPix Max?

We need to know these two facts to ascertain whether the problem is on your phone’s end or the PicoPix end. Please also inspect the USB-C video port for any damage.

Your phone should already support USB-C video and also “Dex” desktop experience. We have tested this.

Hello, DEX works for sure with phone - - > pc. The other tests are a bit more complicated because I don’t have suitable hardware at reach, but I will try to gather the info.

Hi @Philips_Support_P, I was able to test USB C with a Xiaomi Redmi note 8 Pro. In this case, the PPM switches on the “no signal” page (but that happens also if I just plug the unconnected cable), but I see no pop-up on the phone to cast video via USB.
The USB port seems integer.
Again, I am not sure the phone is supposed to be able to do that, I can never find in the specs “able to send video through usb C without adapters”

I have an USB-c -> USB-A adapter, can I test the port with something else, e.g. a memory stick?

Incidentally, but it’s probably an unrelated issue, after this test the airmote could not pair anymore with the ppm, even removing all bluetooth devices from list and re-doing the pairing. I had to do factory reset…

Did you get the green LED to light up in addition to the blue or red one when you did this? Unless that green LED comes on the video alt-mode hasn’t been activated (for one of several potential reasons). And yes I’ve also noticed that the projector will incorrectly switch to “USB-C video” even when just inserting a cable that otherwise isn’t connected. That’s a bit weird as the projector knows very well when there’s a true DisplayPort video source plugged in (green LED lights up). Only then should it switch over. Hopefully a firmware fix.

Which is the usb A port here…I used that.the one next to the hdmi…? Not working on that

The one between the HDMI and the headphone jack.

It was the only one I was inserting the flash drive in…My problem solved at least for the usb reading part as I just came to know I was supposed to go to file manager and select usb for my disney apk file.
Though all I’m getting is another aptoide tv hich gives me a disney version that shows region isses

Hi, my USB C on my pico pix max one does not support video output and it does not charge the device. I have used 3 usb C cables. 1 from my samsung note 20, one from my onexplayer and one thick one rated for VR gameplay and all do not charge and release video output. I have also used 2 charging bricks (20w, 65w), and 1 powerbank (20w). All my devices tested can do video output to other exeternal USB devices. Do you think my unit has a defective usbC port?

I’m having issues with usb-c as well. Both my Samsung phone and laptop can not be used. Phone won’t trigger a signal and with the laptop the image keeps flashing. Tried different cables, one specifically intended for video via usb-c and all devices powered. Anything that can be done?