Wifi Connected but not connected

First time turning the projector on decided to just update the software right away to get it done. Connected to the Wifi at home and it displays “connected” and the name of the wifi. Then when choosing to update the software it says “No internet connection!” Even though it shows connected the wifi symbol doesn’t display a signal. So, no way to update. No welcome or setup menu upon turning it on. Not sure if that is normal but clearly no way to update this device. After all the wait it certainly is a disappointment to encounter such a simple issue untested and sent to the customer. :expressionless:

Any suggestions on how to convince the device it is connected to the wifi?

Have you tried updating off-line?

I have not tried this yet. However, is this a common problem that others have encountered? The wifi connection clearly isn’t working even though it displays the word “connected”. Didn’t try any other features because of utter exasperation in this first attempt to use the device. Will the update correct the issue with internet connection? If not, then I am still back where I started. It’s my first time participating in one of these projects but clearly there is a reason why people pay more for a tested product.

I haven’t tried since my PPM isn’t even manufactured yet. Also, I don’t know whether the update will help you with the connection or not, but it’s worth a try.

I have had a fair share of electronics with different kinds of initial problems like this and I don’t think the PPM is a particularly bad case. When you buy something that is not yet thoroughly tested by consumers and in the initial stages of the update cycle it is always a risk. Testing wifi is especially problematic, since there are an infinite amount of combinations of network appliances and local conditions.

Have you tried connecting to different networks? That might help you to find out whether it’s your PPM’s wifi or the router that is at fault in your case.

Just to chime in to say that I updated the firmware via WiFi without any issues. The download took a couple of minutes. Then update another few minutes. All in all the PPMax was updated within 10 minutes.

Try setting up wifi manually, the first time using, instead of using a wifi signal found by the PPM. Put in the SSID and password for the wifi signal, you want to use. It should connect and show the signal strength icon in the top right corner. I had the same problem, when I received my projector.

Received my unit last night with same problem. It was not picking up the address but said the network was connected. I deleted or unconnected the wifi network ( when prompted by the PPMax in the Wifi settings) and then reinstalled it having to put the password in again and it worked.

Be aware that being connected to you home WiFi signal is not necessarily the same as being connected to the Internet. Think of the WiFi signal as a cable. You have successfully plugged in the cable, but if for some reason the projector is not getting an IP address from your router (check DHCP on the router) or is not getting the Gateway IP address (normally your router’s IP address) or does not have a valid DNS server address (normally provided by your router), then it will be connected to your WiFi but not able to access Internet sites. I don’t yet have the projector to see how the network configurations are accessed, but I assume somewhere you can access advanced network settings and check these things.

1 Like

Thank you for that advice. I did this and it was able to connect correctly. It’s a good thing there is this forum and people are willing to help out.

1 Like

Encountered this too… for the first connection, you have to wait for the device or you can turn it off and restart the unit after 10 seconds.