Aptoide help - not able to download anything

I am a UK backer and am overall happy with the device. Less happy with aptoide. I can search and find apps, but am unable to download any.

I suspect this may be related to my wifi router. I am with BT broadband, are there any settings I can change to allow app downloads?

Any other help greatly recieved.

Hi @MikeR.
Welcome to this forum.

Are you able to download things through the Firefox app ?

Yes, firefox works well

How exactly it does not work? Perhaps you did not allow app installation when you were asked?

I don’t recall this as a step I encountered. How could I now give permission for this, i can’t see an option in settings?

Follow this How to access hidden (default) Android settings? and search in there, there’s a place to give an app the special permission to install other apps.

1 Like

I’ve been to the hidden settings and the Aptoide app has the correct permissions to download. Unfortunately I still cant download within Aptoide - the download bar never moves from 0%

I’m on BT and have always had exactly the same issue, no idea what causes it, all permissions are active, other apps don’t have internet issues. Sometimes it will randomly let me.

If I mess about clearing the app cache / data, removing install permissions, switching wifi on/off I can sometimes get it to work for a short time. I managed to update 2 apps today! It seems to get stuck at the download phase. It’s a proper bag of sh##e.

Can you try the following:
Download APKPure from


using a laptop or PC, then copy the file to a USB stick and install it using the File Manager from the Settings menu. Once installed, see if you can download and install programs with it after granting it the right permissions (see above).


I’ve found a workaround (I’d actually found it ages ago but forgot🤨 - I’d even posted it on another thread). Aptoide and BT Broadband don’t seem to get on, I don’t know if it’s their router or if BT blocks it for some reason, everything else on the PPM works fine with them.

So I tried turning on my mobile phone’s hotspot wifi and connected to that instead and it seemed to work ok.
Wish I’d remembered that before I spent hours yesterday trying to get aptoide to work again!


Aha, so BT Broadband (or their router) might be blocking some component or site that Aptoide needs. :bulb:

If you have a chance, try visiting https://en.aptoide.com/ from any other device connected via the same router, and possibly also via a web browser on the PPM, and let us know what your results were!

Good to know it’s not something inherently wrong with your PPM then most likely, this is troubleshootable or by-passable.

Aptoide doesn’t work on my phone when it is connected to wifi either so yeah it’s something to do with my internet provider or the router and aptoide. Why just aptoide though and nothing else I have no idea. Maybe they think it’s an illegal site?
Could be a big issue in the UK. BT broadband are probably the biggest broadband provider.

1 Like

Could be worth doing but with the PPM instead of a games console:

To me this isn’t what DMZ is used for but for home routers this is what they set for them to help with blocked ports and stuff.

I agree I think it is a BT restriction. Unfortunately BT are also my mobile provider so am unable to use that as a work around - having already tried and failed.

1 Like

Would a VPN help perhaps? Getting to the Aptoide websites from somewhere else?

Has anyone asked BT about this? Might they be blocking Aptoide by mistake?

BT are my mobile provider too (£5 discount :joy:) but it works over mobile.

1 Like

Im registered with vpn but again can’t download the app if there’s somehow I can get on to vpn it should help the download process

I’m having problems downloading tried Firefox will download something but when I switch to file manager there’s nothing there