Can't connect to Wifi

Hello, I just received the Picopix Max… Apart from it being very buggy (half of the times I click on something it goes back to the main dashboard, USB C video input doesn’t work, 4 corner calibration doesn’t work; etc.), I can’t even connect to my wifi network because it doesn’t see any wifi network at all. The thing is useless for now.

Any idea?

@PhilipsNono @PhilipsEngineering

^ This might get you further, there are known issues with the Wi-Fi settings apparently.

Hi, I am experiencing the same issues, it’s the most frustrating thing to not be able to connect to WIFI for an apparently enabled WIFI device. Also, the projector crashes and 4 corner calibration does not work. Since I was unable to connect it to WIFI, I connected the handset to my Android mobile (Samsung Galaxy Note 10+) via usb-c cable, which works for a while, then shuts off after about an hour, it all seems very buggy. Will there be a solution from Philips? The projector crashes on the hour (as a continuum) rendering it pretty useless. @Philips please tell us if these issues can be rectified via an update or will swap out units / refunds be provided? I am so disappointed, waited months for this thing.

1 Like

Yeah. The extent to which I use the android OS on this device is merely to switch input to HDMI and run all my apps off my laptop. My wifi never stays connected, and all the major apps I want to use work only after a half hour of troubleshooting and bug work arounds. I’m on the latest software, and it is still nowhere near ready for prime time.

Hi @sandman1330 you are right since we are working to perfect it based on our backers’ feedback. It is not available to the general public yet. We are releasing frequent SW updates to Indiegogo backers.

Rog. So can I take this statement to mean that you’ve acknowledged there is a bug in the wifi, and are working to correct it? My wifi drops regularly, it cannot hold a connection reliably. When it does drop, it doesn’t allow me to reconnect, I have to go into the hidden settings and try over and over again before it will work. It keeps showing my network as disabled in the hidden menu. I’m on a clear 5ghz channel, projector 5ft from the router, and all my other devices work fine.

I have a gut feel it may be related to the ExpressVPN app blocking the connection, but I’m not sure…

Uninstall the VPN app then and try again I would say.

I need the VPN app. I’m deployed to a middle eastern country where they snoop on everything we do online.

1 Like

I understand that. But for your troubleshooting process, surely you can miss it for just the duration of your test with the WiFi connection dropout? Once you’ve ruled it either out or in, you reinstall and report your findings back to us and the Philips team.

The WiFi network module with Bluetooth 5 included, is indeed a bit less stable than the older BT4 chip we originally had. But in our testing the difference was not a huge amount so we decided to keep it, for future proofing and due to popular demand. The drivers and software continue to improve and it’s only a matter of time before it’ll be just as stable as the BT4 based module. The main reason is interference in 2.4ghz range so if at all possible, use 5ghz network.

Btw I have been fooled by ExpressVPN many many times into believing my network wasn’t working! Please disable it and test it to rule it out as @IvoG suggested.

1 Like

Thx for the help, I’ll give it a try later, I need to take a break before I break the thing. Nothing seems to want to work tonight, from Netflix to Plex to the wifi, I can’t get anything going.

I’ll play around with it tomorrow when I’ve calmed down :wink:

I uninstalled expressvpn and still no dice. The wifi won’t connect, when I select my network it shows up briefly in current network, then disappears. It cycles like this a few times then just gives up. This is how it goes about 25-50% of the time. I haven’t found a reliable workaround yet, other then restarting the projector several times until it decides to behave.

That’s a bummer.

  1. What frequency is this WiFi network of yours, 2,4GHz or 5 GHz?
  2. Have you tried creating a hotspot on your phone and connecting to it?
  3. Have you tried different networks elsewhere?

None of these questions excuse the fact that it should work with your WiFi network, but they might help to narrow the issue down.

Using an uncluttered 5ghz band at close range.

I’m limited in my options with tethering and other networks because I’m overseas, but I will maybe try using my laptop as a hotspot. However, none of my other devices have trouble on this network.

In the hidden wifi menu, I am getting “wifi network didn’t accept connection.”

It also lists under my network, where it usually says “saved” it says “disabled”

I’m completely unable to get connected now.

Aha! The passphrase might be wrong! :bulb:

How are you entering the wifi passphrase, with the onscreen keyboard? The focus tends to stay stuck at the letter Q, and when you press the OK button the Q is entered instead.

If you do, just see if you can connect to it; you don’t need to get actually internet connection at all, just trying to join a WiFi network. Make the hotspot password free or having a short & simple password just to see if you can keep connected. If that works, then it’s the inputting of the password that somehow fails.

Dive into any Starbucks or McDonalds or even an Apple store and try to join their WiFi network as a test.

Haha, I’m not sure there’s an apple store or Starbucks near where I am :wink:

The passphrase is correct, it does connect on occasion without having to re-enter it. The network and password are saved, it just seems to decide on its own when it wants to work!

I’ll try the laptop tomorrow. It will take a longer term test to see if the issue comes back, since it seems to be so off and on. I’ll let you know!

1 Like

But what about if you use the default Android wifi settings? The PPM wifi settings screen seems to be bugging out, but the android default UI shouldn’t have this problem.

Can you please try that?

Prashant,

Thank you, but it is the android (hidden) menu which gives me the error messages I’ve outlined above. The regular menu gives no error messages, it just doesn’t connect. Neither works.

So I’ve reenabled the 2.4ghz band on my router, and the 2.4 channel connects reliably, every time, despite being a very cluttered band in my area.

The 5ghz is still hit and miss, sometimes it works, sometimes it doesn’t.

Unfortunately the 2.4ghz band is too slow for Plex local streaming.

Back to HDMI I guess.