Can't connect to Wifi

Does this hidden settings menu still work? I can’t seem to open it from the “about” menu.

1 Like

I can still access it (a few OK presses on “Software Version”).

WiFi connected with no issue at home.

Once at work, to run a presentation, I could not connect to the WiFi whatsoever.
Can’t connect to my phone or any WiFi around.

What is that dark magic?

Please elaborate on the WiFi router model(s) / frequencies attempted which worked and didn’t work.
To discover the dark magic we need more data.

Multiple router same SSID, 2.4GHz and 5GHz.
Channel 11 on the 2.4GHz
Channel 36 on the 5GHz

Tried moving around the office for less loss (with the help of a WiFi analyser)

Use my phone as hotspot failed too. 2.4GHz

Hi all,
I’m experiencing the same bug as you @HVC , but with a fresh new Screeneo U3 baught 2 days ago :
I’m unable to connect to the WIFI with the settings “WIFI device disabled”, “Please turn on the WIFI”. But when I try to switch it on, nothing happen, it stays off. Yet it worked when I started it for the first time but not anymore.I already restarted everythning (factory reset) but unsuccessfully.
Did you fix it since your post ? Any idea @Philips_Support_P ? Any update to fix it ?
Thanks a lot

Hi there @ArthurD, sorry to say no - this unit is pretty rubbish, its been in the box since we received it spent days trying to get it to work, took to various locations (office, home with super sound wifi networks), nothing works. Beyond disappointed in this product. I did exactly the same thing as you, just an unfortunate purchase as far as I’m concerned, wish they’d release a solution in the way of an update that solves the issues, not sure it’s actually possible… too many things wrong with this projector to spend more time on it as far as we are concerned.

I just came back from troubleshooting a PPX with WiFi connection issues from a fellow backer in my hometown. I took my fully working PPX with me and first he showed me his, where the unit would see the networks, connect to the one he had set (and also reset when I was there), only to not get any IP address and the WiFi to turn itself off completely. Each time we went back into the WiFi settings and turned the WiFi on, it would try to connect and then just turn the WiFi off by itself. Not even connecting to a hotspot would work.

So I took mine out of the bag and proceeded to connect it to the same WiFi network as he had tried. Lo and behold, my PPX did exactly the same as his! :astonished: I could not get it to connect to anything, not even my iPhone’s hotspot, the WiFi would just crash.

So we had successfully reproduced his issue on my unit which has worked perfectly fine so far at my home.

I then realized that the flat he lived in was bursting with WiFi networks. My laptop and iPhone were picking up at least 16, sometimes different than that even. I believe that the sheer amount of WiFi networks is causing something to overflow and crash the WiFi stack.

Good news is that I’ve managed to reproduce the issue, and got a log file of the unit while in that environment. So now the engineers may finally be able to discover what’s going on once I send in my findings.

For those that reported this issue here: how many networks do you see in your phone / laptop / PPX?


Hi @IvoGrijt @HVC Thanks for the quick answer.
Indeed I live in a flat where I can see a very large number of WIFI networks. So It might be the source of the trouble as @IvoGrijt explained it. Now, there’s nothing that could limit that. I hope your findings will allow an update soon… Can you keep in touch ?

1 Like


Is it possible for you to try this suggestion:

Thanks @imdevu but in fact I can’t even try to connect to my network since I need first to “turn on the WIFI device” in the settings of the Screeeo, which is impossible since it turn itself off. Currently I don’t see any WIFI network with the projector (but a lot with my computer in the same room). In these circumstances, changing my WIFI channel won’t change anything ? Or am I missing something ? Sorry I’m not very familiar with this king of issues.

download a WiFi analyser app similar to this one here on your phone and update your router to transmit to a free channel. Not sure if it will help if the setting is not stable.

Alternatively try going to a different place (safely) and try to connect your mobile in wifi mode (tethering) and see if that helps.

1 Like

Like @ArthurD said, once the PPX loses its mind over the many networks, you can’t join it to anything, regardless of the channel. It will just crash the WiFi stack altogether.

@ArthurD: subscribe to notifications from this thread, when and if we find a solution I’ll post here and you’ll know.

1 Like

Thanks @IvoGrijt, suscribed and looking forward to hearing from you

Interesting that your PPM found it problematic when you saw only 16 networks. That is not a very high number. When I am at my apartment my phone can currently pick up 52 networks, if I count both 2.4 GHz and 5 GHz. It will be interesting to test what the PPM decides to do after waking up in that environment. The parcel should arrive tomorrow.

Is it just the number of different options? Or does it matter whether the PPM:s router shares its channel number with one of the others? There are no (non-overlapping) free channels here.

My PPX didn’t share anything with any networks at the other backer’s location, but I could not even connect to anything, not even to a hotspot on my iPhone which I had never had an issue connecting to.
The router I tried to connect to, the backer’s, was at 2 meters distance, so it’s not about the signal strength.

1 Like
Hey guys,

I dont know if I am the only one experiencing this problem, but I cant seem to connect my PPM to my own wifi, it keeps going back to the setting menu when I try to do so, and if I connected a network, it doesnt work… any ideas?

I select my network, and then it just goes back to this screen;

Which firmware are you on? If not on 1.1.02 then check and follow this INFO: How to do offline software update?

Had the same issue at first and what fixed it for me wasn’t the firmware update but just resetting from scratch our mesh router (orbi) and somehow it discovers, connects and stays connected now. Still, the PPM shouldn’t have issues as basic as Wifi out of the box.

I updated the system, still the same problem…