Downloaded Netflix videos offline playback


When playing your downloaded Netflix video and you have no internet connection, you will get an error and the video won’t play at all.


  1. Go to Settings >> About
  2. Click/select the software version repeatedly until a new menu appears on the right side of the screen.
  3. Go to Data/Time settings and enable automatic settings even if it already appears to be set to automatic.


PPM’s settings app doesn’t seem to have automatic setting for date/time. Netflix requires this setting to be set to automatic. I guess this should also be fixed to the settings app as it is indeed quite hard to find your timezone in the current UI and no automatic option.


Managed to download an episode of a tv show on Netflix over 400MB it claims, amazingly it done it super fast much faster than what I normally experience on my pc, and after turning off wifi to be sure I was able to play it offline, but where is it stored? I can’t find the files, I also have a new sd card inside formatted to exFat

You can only play it inside the Netflix app. I don’t think you can get the file itself and play them.

1 Like

Ok fair enough I’m guessing that’s for copyright reasons, but it would still be good to locat within file manager to delete instead of only being able to do it through Netflix ,
but then I noticed once that’s downloaded the home screen for Netflix changed and using the air mote you can no longer navigate any where for Netflix besides what’s on screen which was the show you were last on,
Edit the whole screen freezes for the airmote no commands work besides the home key, but use an attached 3rd party mouse that can

Hi @ThunderStrk are you using the ‘mouse mode’? The arrow keys don’t work very well inside Netflix.

No I was using the arrow keys only to navigate, I even switched off all other bluetooth devices around me in case of interference, but I will test it again tonight and see.

Ok now I see what you mean , so it’s the mouse mode that needs to be used instead of the arrow keys, at first I thought you meant the mouse mode was the problem, but it’s weird that the arrow keys do work at the start for a while then stops for some reason, well do hope this can be fixed

I have the same issue.
Arrow keys worked fine until I downloaded my first Netflix show, and now as long as there are any downloaded shows that enormous blue banner sits permanently at the bottom of the nav screen and gimps the button navigation.
My AirMote mouse mode gets flaky at times, at which point Netflix is inaccessible until I do a full power cycle to restore mouse mode.

1 Like

Can you post a picture of what you’re experiencing?

Yes that blue banner is always there when you have anything downloaded, but my air mouse pointer did manage to navigate around this until the cursor function totally failed which I have opened a ticket for and waiting, either way I did order one of this based on positive reports here

I’d like to hear your review on that keyboard for use with the PicoPix, thanks TS.
My AirMote mouse-mode still works most of the time, but knowing that it occasionally fails makes me concerned about mouse-mode being the ONLY way to navigate by remote.

I think the problem isrelated to these Netflix pushed posters that now come up on launch.
I did manage to escape this trap with the arrow buttons once by going to the right and then down, but haven’t been able to replicate the escape since.

The way to navigate when the blue banner is displayed is to press the mouse button to bring up the pointer on to the screen and think of that pointer as the tip of your finger, then press down and hold the mouse button and move the remote in an upward motion to drag the screen upwards to reveal more of that page ,
You are basically simulating finger scrolling on a phone/tablet on a device without a touch screen by using a pointer,
Because this Picopix after all is using a tablet UI
the remote I linked to earlier has a scroll wheel which will make this much easier to do

1 Like

Although I appreciate your patient and thorough instructions, I’m quite familiar with mouse mode and have no problem with the AirMote except, as I said above, when the mouse mode glitches and won’t bring up the cursor.
When that glitch happens I’d be fine with just using the directional buttons if they worked in this particular trap, but am stuck without a reboot.

Oh right got ya, I just didn’t get what you meant by your mouse get flaky at times earlier, then you should email support and see what they say, as for a review of that remote someone has already done it, Rii i4 Mini Bluetooth Keyboard with Touchpad and Scroll Wheel

Will check that out, thanks TS