Express VPN not working on picopix max

Is anyone else having issues with getting express VPN to work with either Netflix or amazon prime?
I have tried the following:

  • changing the current location, I have tried alot of the American locations
    -changing the VPN protocol.
  • I have checked for updates for express VPN, Netflix and amazon prime.

Is there anything else I can try? I can give more information if required to diagnose this issue.

I can get express VPN and Netflix to work on my phone under all VPN protocols and most locations.
Thanks in advance.
Jo

I have the same problem -> e VPN is able to connect - there is internet as I can surf. I can even login to netflix / amazon without issue and I see the country specific content come up. But when I try to start streaming, I get the proxy error. I think its an e VPN settings thing, but cant figure it out yet.

This is the same as what I am getting. I am not sure what other settings I can try or if this is either an issue with the VPN or the Netflix/ prime apps.

Same here… I can stream Netflix to every compatible device in my place … except the pico

Check this topic

There are some solutions that apparently worked for some but unfortunately it’s not completely solved yet. @PhilipsNono is in contact with EVPN.

Hello, a new version of Express VPN will be out in 7 days. We will test it and get back to you

Thanks guys! I have seen the old thread. I tried setting the VPN settings to TCP. That did not help. I am yet to try the DNS proposal - but could you remind me how i can do that? Isnt it part of the ‘developer unlock’ of the projector?
“You can also use the DNS from Express VPN directly inside the Wifi option of the projector.”

Cheers