Hdmi cec not working

hi all, my hdmi CEC is not working, (hasn’t worked since i received it about 4 weeks ago). i had almost cancelled my order as the chromecast and other Android tv allowing ease of smart home integration were no longer included and there was no CEC sorry allowing for ease of smart home integration included.

i was ecstatic when i found out it would be available… but now totally disappointed as i suspect it may be a return. I’ve turned on all combinations of the CEC controls in both the ppm and my cec devices (Xiaomi miboxes), replaced all hdmi cables, turned off developer mode on both devices (have also tried a plethora of dev mode options on both devices) , and verified CEC works on my other CEC compatible projector. oh yeah have factory reset it, as well as trying it on both 1.027 and 1.029.

can anyone suggest anything else? any tests i can run perhaps? i can’t identify anything in the rockchip tests but my translator seems to be a bit…off. i do feel that the plugs are quite stuff, and the case potentially too loose so perhaps it’s a connection problem…i really really don’t want to return it as it’s been such a long time coming… and for the most part the test of the machine seems great.


1 Like

8 posts were merged into an existing topic: HDMI-CEC Support