Image frozen and very loud (fan?) noise

Today while I was watching Prime Video, my PPM suddenly froze, I got a very loud noise coming out of the unit (sound like a mechanical noise/rotating part out of axis, relatively high frequency - sorry, I’m not authorised to upload the short video of the noise) and the remote and the unit were unresponsive (Impossible to go back to the home screen for example or to have any key responding to command or to stop the unit via the remote). I unplugged the charging cable but it did not change anything.
It took me few trial to stops the unit with the stand-by button (few trial of long pressing on the button, like more than 10 seconds). After restarting the unit (waited about 2 minutes after stoping it), it worked just fine (I only used it for 30 minutes after the interruption).

Prior to the issue I had the unit working fine for few hours in a row in different mode (screen mirroring, USB-C connection and Prime Video). The unit was not hot, even not warm as you could expect from a projector like this running for few hours…

Anybody with similar issue? Anything to watch to avoid it happening again? Any log file I could download to support some troubleshooting if necessary?

I had no major issue with the PPM until now, only the WiFi dropping off after 1:00 watching movies (even with only one wifi network (2,4GHz and 5 GHz) in a remote area…), but disabling Bluetooth seems to make the trick to watch a full movie without interruption.

1 Like

Hi Olivek76 and @PhilipsIvo

I am experiencing exactly same problem.
I’ve been using my PPM about two months since got shipped to me in Canada Toronto.
The first incidence happened about a month ago.
Since then the frequency is getting shorter and now it happens almost every day.

@PhilipsIvo, I don’t know how many peoples are being suffered from this issue. But it seems very critical and getting worse day by day. And wondering if Phillips is aware of this problem and working for the fix.
Would you be able to let me know how I can solve this issue on my PPM.

Best Regards,

Joseph.

1 Like

Hi @Olivek76 @PhilipsNono, @PhilipsIvo, @PhilipsEngineering

@Olivek76 are you still having issues with this?

I have had this exact issue and it seems to only be with PrimeVideo for me (although Netflix hasn’t been watched in a couple of months for me, so that might be a problem too).

When watching PrimeVideo, the PPM seems to lose frames and become jittery (which at first I attributed to my internet/PPM needing to buffer the video) then the video completely freezes and the audio continues. If i do not press back on the airmote in time, the PPM completely freezes and it is unresponsive from the remote and the touchpad.

The first time this happened, my PPm wouldn’t even switch off, I tried to manually switch it off from the power-off button for 20-30 seconds at a time and I just had to let the battery die on it. Since then however the unit power off button has been able to switch it off.

As you’ve mentioned, the fan becomes VERY loud and I would add that this has only happened so far when the unit has been plugged in.

This problem has been occurring for a month, for me, and seems to be occurring everytime I use PrimeVideo. I have tried to update PrimeVideo, remove and then reinstall PrimeVideo but I haven’t so far done a complete Factory reset.

What should we do about it Philips staff?

1)I have noticed that this is a problem which has been highlighted by other people under a different topic, should I post this there too?
2) Is this software or hardware?
3) Do i need to open a ticket to start a technical query or even initiate a complete PPM swap?

Thanks in advance and keep up the hard work, I love my PPM <3

David

@Olivek76 and @JosephSJPark, this topic seems to be applicable too:

might be worth posting in this topic as well :slight_smile: