Internet Connection Issues

I’ve been using PPMax for few weeks now but one thing annoy me a lot is the wifi issues. Some time when you switch on the ppmax, it takes few minutes for the time zone to be switched. If the time zone is not switched successfully it means you are connected to the wifi but no internet connection. While some time it takes around 5 minutes to successfully switch the time zone, but the internet speed is super slow, can’t even run a YouTube video. So I tested out by connecting my PS4 via HDMI and it is fine, everything run smoothy.

This issue happens very frequently, I wonder anyone encounter the same problem as mine. Please help!

There might be different factors that could affect your issue. Your PPM, your wifi router, the combination of your PPM and router, etc.

In my case, I don’t remember having this issue in the 2 places I’m usually using my PPM.
Perhaps you can try connecting to another wifi connection (i.e. mobile hotspot) and see if the same issues happen.

I am facing the same issue now. Its been fine for a couple of days and this issue pops up. It takes for ever to connect to internet. Please see the time on the image attached to your top right. The timezone is not synced yet and its been turned on for 5 mins

@PhilipsEngineering can you please help?

Could you please update (edit) your post with the following information:

  • Router brand and model:
  • network frequency used: 2,4GHz or 5GHz

Also, are there any other WiFi networks you could test, like a hotspot from your phone or a neighbor’s WiFi? If you can and do, please list the same info and results.

This will help narrow down the issue / solution tree options.

Hi @PhilipsIvo,

Thanks for the reply. I am using 5G and the modem I am using is Belong 4353.

1 Like

Have you tried a 2,4GHz network? And what about a hotspot from your phone?

@PhilipsIvo yes I tried 2G as well and also mobile hotspot. Even though it says it is connected to wifi while setting up the connection it still isnt actually connected. And the timezone still remains same

@PhilipsIvo I just did a factory reset and tried to connect to internet. It works and the time syncs as soon as it says its connected.

Also I tested the restart. So as soon as its restarted it syncs in the timezone which means its connected to internet.

Okay, so a factory reset cleared something up that was wreaking havoc.
Were you using a VPN by any chance?

Good to hear it now works though, let’s hope it stays that way!

@PhilipsIvo I think the issue might have started when I was trying out the expressvpn trial. I remember it was ON when I turned the PPM OFF. And I think the issue started then

1 Like

3 posts were split to a new topic: Netflix crashes after user profile is selected

I get this wrong date and time thing some days when I turn the PPM on too.
Sometimes it’s fine, other days it’ll take several minutes before both of these happen:

  • Apps stop complaining that they have no internet
  • The time and date updates

I’ve never used a VPN.
Access point is a TP-Link TL-WPA7510KIT, which gives 5 & 2.4GHz. When the internet/time sorts itself out I can stream HD stuff with no issues, so I would say that the connection is pretty stable.

1 Like

You probably have the same SSID set for both 2,4GHz and 5GHz networks. So it tries to connect via 2,4GHz band and doesn’t succeed, then tries the 5GHz band with more success.
If this is the case, try naming the SSID for 5GHz something with 5 in the name.

Been having the same issues. MY wifi is spotty and the AptoidTV app is always showing a atime error message and it won’t let me pass the warning screen… Really frustrated that a simple thing such as wireless connectivity is hit and miss.

I am having the same issue as well… Worked perfectly fine yesterday and today none of the apps are working…!!! Did the the factory reset as well but no luck…

Please assist

Still takes a couple of minutes even with the projector joined to a 5GHz-only WiFi network.

Also having problem with getting the wifi working, it sees the SSID But it keeps dropping and then it reappears? It added both 2,4 & 5ghz SSID’s and in turns the PPM keeps trying to connect but drops within a second when its trying to connect to one the SSID.

I tested all kinds of ways, 2 routers( [D-Link DIR-868L & Netgear WNDR3700), mobile hotspot, internet connection at a friend and tested everything again with firmware 1.1. Nothing works

1 Like