Mouse cursor stopped working

Okay, first time I have encountered a fault so far and hopefully the last, and one that a search through the forums hasn’t helped
Anyway the mouse cursor/pointer for some reason stopped working last night, tried it again today and it’s still the same, rebooted the ppm unpaired the airmote and re paired it, all made no difference, all other functions works well the same as usual, bluetooth is also active so I don’t need to point at IR, it’s only the pointer that don’t respond, it will appear on screen but waving it around hardly makes it move slowly across the top of the screen at it’s own will, even though I try and avoid using the mouse function like the plague but sometimes it is still needed, so I don’t want to lose this function , anyone had this issue before?

Can you try the touchpad and perhaps a Bluetooth mouse also, do those work?

The touch pad on top seem to work fine even though I rarely use it, tried a mouse with usb dongle that works too, my bluetooth mouse hasn’t worked for a while with a button stuck so can’t really test that.

1 Like

The same thing has happened to me. Pressing the pointer button on the remote (using IR) no longer brings up the pointer. I rarely use the pointer as I find it sticks and is frustrating to use. The trackpad works fine. Any solutions?

1 Like

So basically the IR controls still work (not a dead battery) and the pointer still appears but just moves slowly in @ThunderStrk’s case, but no pointer at all for @Steven_Sander.

The pointer appearing but then moving slowly could point to an issue with the gyroscope in the remote.

The pointer not appearing at all could be down to a disconnected remote needing re-pairing / connecting, low batteries (enough to power the IR but not the BT circuitry), or a defective pointer button.

Just for the sake of completeness, could you both try a fresh(ly charged) set of (rechargeable) batteries?

1 Like

I’m almost certain that mine is battery related now, just tried some new batteries following your advice, but unfortunately I don’t have any fresh new AAA batteries at home but half a 20 pack from Aldi, although new it is a few years old sitting in the draw, and immediately the pointer started moving around, a little too fast at times but after a little while it too would go to the top of the screen and become unresponsive, then I tried putting back the ppm generic batteries and it was just unresponsive from the start like before, so I will try to get some good energizer batteries tomorrow to totally confirm it is a battery issue,
I have always thought it was a bad move to package this with some generic battery, it just looks bad for Philips, you won’t see a Sony or Panasonic product with generic batteries they will always give you their own batteries with their remotes, recently I found a cheap Philips personal groomer I had in the back of a cupboard that I forgot about, it must have sat there for 2 or 3 years, I switched it on and it was working like new, twisted open the battery compartment and yep it was a Philips branded battery, this was on a $20 item, I understand we are backers from a crowdfund campaign and they might want to cut costs as much as possible, and I can live with that and get my self some better batteries, but I do hope with the retail version they will ship it with Philips batteries

1 Like

Okay batteries are not the issue, bought a 4 pack of the best batteries I can find, Energizer Ultimate Lithium

And it made no difference hardly any response, tried all 3 sets the original that came with the pico the Aldi house brand and this Energizers at $18 AUD they were all the same today, what’s weird was the Aldi batteries worked briefly at start up yesterday then became unresponsive which is what lead me to believe it too might be too old and didn’t have enough charge left, I was confident these new Energizers with a 20 year shelf life would solve the problem, so that’s a bit disappointing .

1 Like

Stop assuming and break out your voltage meter, start measuring the voltages to be sure!

1 Like

I shall test mine shortly by repairing and replacing batteries.

Just an update, after about 2 days with the Energizers I woke up one morning and found the remote totally unresponsive, I can’t turn it on the red light on the remote doesn’t flash, nothing, at first I thought the remote was dead, then I tried putting the Energizers in another tv remote and confirmed it’s the battery that’s dead, a brand new premium top of the range battery just died after a few days? Maybe guess it can happen even though I’ve never had this happen on a cheap battery, but just in case it’s not the PPM remote I decided to put in some Aldi batteries again, and yep 2 days later it too is totally dead,
Now I’m really baffled as I really don’t want to say the PPM remote is killing batteries and I can’t see how the remote can drain a battery or kill the cells in 2 days, but I have no explanation for what’s going on.

1 Like

Perhaps one of the buttons is catching on the housing, causing it to be pressed all the time? Can you post a pic of the front of the remote please?

The remote is fine no buttons are catching or stuck, if it did I think the lights should be constantly flashing and I should see it, and I haven’t noticed that.

1 Like

Can you check with your cellphone camera if the remote isn’t sending an infrared signal.
If a button is stuck (internal) the red led on the front will only blink a few times and stops blinking, but the infrared led will keep transmitting.


Yes you’re right the red led on the front does stop blinking, I just tried this with the phone camera but I can only see the infrared flashes when I push on a button , so no buttons are stuck and it’s not sending out any signal unless I press on a button

1 Like

This is a strange one. I don’t think I’ve ever replaced the batteries on my AirMote. It’s been running since December or probably earlier, on the same 2 batteries.

Can you disconnect and unpair it, then pair it again, and see if it continues draining?

Also, try to eliminate the projector by testing these 2 cases:

  • disconnect and unpair, then don’t pair it at all to the projector, just use it in infrared. Does it still drain?

  • connect the AirMote to your computer or phone instead of the projector.

With this info we can isolate the condition in which it happens.

If it only happens when connected to PicoPix Max:

  • Are you using 5GHz WiFi, or 2.4 GHz?

  • is your PicoPix Max placed far from the remote?

  • are you using Bluetooth speakers?


I will try your suggestions but to test battery drain more accurately and quickly instead of waiting for a few days on each test I will need to pick up a multimeter when I get a chance my last one has gone missing for a while, but I have put in another 2 batteries and so far it’s been more than 2 days and it’s still going so maybe the last 2 pairs were duds, but just to clarify the airmote worked fine for the first two months or more that I had it, this battery issue only happened after the pointer became unresponsive and unusable and it still is,

I use 5Ghz wifi
The airmote is very close to the PicoPix placed behind the bed,
I do use bluetooth speakers as well as the inbuilt one

1 Like

this battery issue only happened after the pointer became unresponsive and unusable and it still is,

Do you mean your AirMote is not working correctly? It could be defective.

Yes the remote is defective hence this thread the battery drain I noticed afterwards, and last night 2 more batteries just got drained not totally but the flashing light on the front is very faint even in a pitch dark room, so waiting to hear back from support I will just take out the batteries when not in use.

1 Like

Just an update on what’s happening, after almost a month not hearing back from support I decided to email again and actually got a quick reply asking me to fill out a return form, but the confusing bit was I didn’t want to return the projector only the remote, I was assured I can choose what part was defective and yes I can, but I haven’;t heard anything back since the 31st of July after filling out the form,
Oh and since last weekend my charger stopped working the battery is drained and won’t turn on, I do have a third party charger ordered but that’s taking forever to get delivered, so right now I can’t watch anything.

1 Like

Another update , so far it is getting a bit disappointing with Philips support, @IvoGrijt hopefully you can do something, since filling out the form after July 31st then again replying to the same email on the 13th of August with my charger being dead issue I have not had any replies since the 31st of July, it’s almost September now, come on! what is going on! I know during the earlier stages yes there were many unfulfilled backers etc, but it really should be much more better now, less backer queries with getting their perks etc, yet still no replies? that baffles me, I hate to tag you or anyone here as I’d like to go through the normal process from support, but clearly as I have found out now as others have it really doesn’t work, or as in my case not any more, so hope to hear something back soon.