No Projection after powering on, Can hear audio when connected to laptop playing video

Hi,

Backer 696 here, Like a few others my PicoPix Max is now projecting nothing. I am updated to the latest firmware (updated to 1.1.0). Before the projection death I did a factory reset because it was freezing and unresponsive, and eventually stopped projecting. It is not a power issue, red when charging (using manufactured supplied power supply), blue in use etc. When I power on there is no Philips logo, there is no light coming from the lens, I can hear the fan initially, then it ramps up, then ramps down. I have tried plugging in my laptop to the projector, with hdmi, and played a video, I can hear the audio coming out of the projector. When I pick the projector up I can hear the focus motor adjusting. I have not dropped my projector and the projector is actually really lightly used I got busy with life so I haven’t have a chance to make use of it. I can’t really tell you if the problem got progressively worse, I just made sure the projector powered on and projected then I packed it away till last week when I noticed the freezing. I went through the troubleshooting guide , and my situation did not change. [Troubleshooting: Projector won't power on / no picture display / shuts down soon after starting]

I’m thinking this is not a software related issue, much like the gentleman that experienced the same issue, no projection but was able to hear audio through airplay. Any guidance on how to move forward would be much appreciated.

Thanks,
Sun

1 Like

Hello and welcome to the forum. Can you please provide answers to all the questions like this user did for example?

Also, it seems this user found a workaround. His issue seems the same from what I understand from your explanation. Check this video:

Hope this helps.

1 Like

Hi Vin, thanks for the warm welcome and for the very quick reply. I tried the work around and it seemed to work, I did not get a chance to fully test it out but everything appeared responsive. Upon a couple of my attempts to get the projection to appear I got these instead (I uploaded a couple pictures), I’m just sharing just in case it helps in any way. I also noticed that the projection issue will be addressed in the next firmware update, you guys are great!


Check Power Adapter and USB cable

  • Are you pressing and holding the power button (on the projector or the remote) for a few seconds? YES
  • Are you using the supplied power adapter and USB-C cable? YES
  • Do you see red/blue flashing LED on plugging in the charger? This means the power adapter you’ve connected is not supported. Please use the supplied power adapter. NO

If you’re using the supplied adapter and cable, continue to the next section.

Check battery charge status

  • Make sure the projector is powered OFF. YES
  • Connect the power adapter to the projector. Make sure you plug it into the right side USB-C port (charging port), not the left side (video port)! YES

Check display problems

If your projector can turn on but doesn’t display any picture, check this as you power on the projector:

  • Do you see the white Philips logo startup screen?
    Yes initially, but after it freezes and I power off and power on, No.

    • if yes, but there is no picture afterwards, check that all cables (HDMI / USB-C) are unplugged.
      Checked

    • does pressing the home button on the remote or touchpad causes the home screen to appear?
      NO

    • does pressing the autofocus button on the remote show the focusing screen?
      NO

  • Does the projector power off shortly after showing the home screen? It could be a thermal shutdown. check next section.
    NO

Thermal shutdown

If you don’t see the Philips startup screen, or the projector powers off soon after starting up, check the following:

  • Do you hear the fan spinning up when you power on the projector? NO
  • Do you have at least 30 cm free space on all sides of the projector to allow free movement of air? Yes
  • What is the altitude of your city? (the atmosphere might be thin!) At sea level
  • What is the room temperature where you’re using the projector? 21 Celcius

new firmware update to address this issue is already out have you updated?

Apparently only if the issue started with 1.10 firmware, couldn’t find the post where it was mentioned, saw it earlier today.

Edit: This PicoPix Max dead on arrival

1 Like

Hi All,

I am still on firmware 1.1.0, I downloaded the latest and was going to update, but I am unable to because I can’t seem to get to the menu option. The device would either not project ( so I would do the work around 50/50 would work), and when I could get it to project I would begin to navigate to the settings menu and the projector would freeze. Other times I would turn on the projector and it would hang on the Philips white screen, some times with the progress circle which eventually freezes, and sometimes with out the progress circle. Even if I could get to the update option not sure if that would be a good idea. I just uploaded some photos, that were projected, I took in the past 10 minutes of powering on and off.

I actually got the device to boot properly and it is working, I’m not sure if I should try to update or not so I will wait for one of the Moderators to advise.

Just giving an update, I left the projector streaming Youtube just incase someone got back to me, I left for maybe 30 minutes to eat lunch and the audio from Youtube was playing through the projector but the image was frozen. I just ended up shutting down the projector and called it a day.

You are having the same issue I am experiencing. I am pleased the YouTube workaround video is giving you a chance to see then PPM in action.

I also witnessed some unusual screen patterns when PPM first started up via this method.

It is very frustrating … and I managed to upgrade to v1.01.1 but I am now finding the workaround unreliable. Especially as v1.01.2 may offer a software fix.
https://community.philipsprojection.com/t/software-update-v1-1-01-v1-1-02-are-available-now/7443/36?u=telboy

Can @PhilipsEngineering offer a downloadable firmware upgrade method which allows an auto run via usb stick plugged in to PPM on power up please?

Hello @Telboy and @k20a you do have a defective unit which is covered under warranty replacement. We don’t have a software solution for this. Please contact our support helpdesk for replacement.

The light-engine related changes in v1.1.02 is a preventive measure, as our QC found some units exhibited this problem but only when running v1.1.00/01. But these versions are not being loaded in the factory, so if you experience this problem out of the box, it is not software related.

Hi Prashant, aww what a bummer. Thank you for replying, I went ahead and emailed support@screeneo.com

I guess you and I both hit the lotto with defective units lol.

1 Like