PicoPix Max does not start (red&blue led flashing)

When I arrived and watched it for a while, the power was not turned on and the red and blue LEDs were flashing. What was the situation?

Check whether you’re connected to the right port. One is for video and the other one is for power.

画像 Port is right. One day after arriving, it worked fine.

Check whether your cable plugged in correctly on both sides.

When I checked it, it was connected to another 35w USB-C. sorry.

1 Like

Hi, I had the same issue. On the same day i bought. Is it working for you ??

1 Like

Hello, this red blue blinking pattern means there is a problem with the power supply.

35W is not enough to run the projector. You need around 65W for full operation and at least 48W to run correctly at all. 15V 2.5A is the minimum recommended spec for third party power supply, if you want to charge while powered off. While powered on, we recommend at least 4.5A 14V supply. This will supply enough power to run, but the charging will be quite slow.

For the best results, use the included power adapter or a similarly spec’d USB-C PD adapter, and charge it while powered off.

4 Likes

Following up on this, my charger died as soon as I plugged it in. USA power outlet. The result is no light is blinking or ON at all so the device doesn’t charge.

1 Like

The same happened to me, any solutions yet?

1 Like

The same? What do you mean exactly by that, there’s lots of stuff mentioned in the earlier posts.

1 Like

Hi IvoG, thanks for all the help I’ve seen you giving out, great work.

What happened to me was the same as Marctux. I got my PicoPix and plugged it in for charging. I had the time to complete the software update when I heard a loud noise (like a small explosion) and all the electricity of the room went off. I’m living in Switzerland a so I wouldn’t think it to be an electrical problem.

I tried charging it again but now when I connect the charger I have no lights at all. I tried a different charger to try to locate the problem and I had blue and red blinking light. I made sure I was using the right entry for power supply. I tried a different cable whit the same base of charger and also had no lights at all.

I contacted phillips and am waiting response. Any thoughts?

1 Like

Yes. Your charger blew and the other charger you’re using isn’t up to required specs.
Open a ticket with Support@screeneo.com and report the defective charger. Once you get a return form you’ll be able to check the box indicating you only want to return the charger for replacement.

In the meantime check the forum thread PPM Power requirements (search for it) and you’ll find the right power specs and some recommendations for chargers that work with the PPX.

I seem to be facing the same issue. The projector was on for less than 15mins and it suddenly turned off. Now it doesnt turn on and no led is coming up on the ppm. I also tried to turn it on without connecting it to power adapter. It doesn’t turn on either. Also please see my comments on another thread - PicoPix Max stopped working while in use, and is now dead

@PhilipsIvo @PhilipsSupport