PicoPix Max One - USB Not Workd for Update or Video

I bought a PicoPix Max One a couple of months ago, and it is a great device.
Despite it being advertised as having USB-C video input, I never managed to make that work.
I have used a video-capable USB-C cable with USB-C video output capable devices, multiple devices, in fact, devices that do work with other USB-C monitors just fine.
Philips just released a firmware update, I thought maybe that can fix it, I tried to update but I keep getting the following error “No USB drive found.”
I tried both USB-A and USB-C ports with a FAT32 USB that is completely empty and contains nothing but the firmware in the root directory.
Kindly find attached a picture of my setup.
Is my device defected? Kindly note that USB-A port does deliver power.

Hello, can you show us the file you have downloaded?

Here you go, I downloaded it from here

(Attachment MERGE_V56_DLP.bin is missing)

A software update for PPM One and no announcement?
What about the changelist?

We made an announcement on Facebook.
I just tested the link and updated my PicoPix Max One without any issue.
Have you tried with other USB stick?

I tried with 2, one 8GB 2.0 and the other is 32GB 3.0, and I formatted them both and it didn’t work.

What type of USB should I try?



This is very weird. have you renamed the file or extracted it?
USB-C is only for Video by the way.

I did not rename nor extract the file as you can see in the screenshot.

I know USB-C is for video but I thought I’d try all ports that can work.

My USB-C USB is also USB-A from the other side.

And USB-C does not work for video, I tried multiple cables and devices

@Philips_Support_N I need to know, is my unit defected? Should I try to replace it under warranty?

Can you please go to Facebook www.facebook.com/philipsprojection and we can talk directly. We can also exchange pictures and videos. That will be faster to troubleshoot

@Philips_Support_N Hello, I have EXACTLY the same issue.
What is the solution please ?
Kind regards,
Fabien Decroux


Hi Guys,

I have same issue.
Have you managed to get the issue resolved? Is so could you share how to overcome this problem please?


hello, we need to understand how exactly you are using the product.
1: which device are you trying to connect to the max One, and to which port?
2: if to the USB-C port: are you using a dedicated USB-C video cable (can you point us out to the link where you bought it) and does your device is compatible with USB-C (laptop phone…)
thank you so much for your inputs, the more pics and video we have the better we can help.

Hi Guys,

  1. I’m using the Neo Picopix Micro 2 TV with Android
  2. Current software version v1 8.60
  3. Have latest version downloaded and extracted to the root of the USB flash drive v1 9.32
  4. USB plugged into the USB port not type C
  5. Flash drive is recognised by android but not by flash tool

1: there is not update for this Micro 2TV software
2: you can receive some software for the Android TV part via wifi
Is there any issue with your USB-C port?
What is exactly the issue with your Micro 2TV?

Hi Guys,

Thanks you for your message,

  1. Your website suggests that there is an updated version of the software, please see below screen shots.

  2. Why is the firmware upgrade softawer not reading the USB flash drive?

  3. My max res is set to 720 but specs suggest full HD at 1080. I awsume that firmware upgrade will sort this issue.